Excel - menor numero superior a otro cualquiera

   
Vista:

menor numero superior a otro cualquiera

Publicado por JOSE MANUEL (5 intervenciones) el 28/09/2011 13:20:55
tratandose de números enteros,quisiera saber si hay una fórmula que localice el menor número que sea mayor que otro cualquiera.
Ejemplo de una fila de siete celdas: 6 23 84 5 17 26 --
Busco la fórmula a introducir en la celda séptima (--) que de como resultado el número más pequeño que sea mayor que la celda quinta (17); es decir, debe aparecer el número 23.
No me sirve ordenarlos primero y luego buscar el menor número en el rango de celdas que sean números mayores que la celda inicial.
gracias por todo
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder

menor numero superior a otro cualquiera

Publicado por jcs (494 intervenciones) el 29/09/2011 08:37:41
Muy buenas,

mira a ver si te sirve algo como esto:

=SI(JERARQUIA(A5;A41:A47)<>1;K.ESIMO.MAYOR($A$1:$A$7;JERARQUIA(A5;$A$1:$A$7)-1);A5)

Un saludo. Juanjo.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

menor numero superior a otro cualquiera

Publicado por JOSE MANUEL (5 intervenciones) el 29/09/2011 12:03:12
Muchas gracias juanjo, funcionó perfectamente.me sirvio para resolver tambien la duda planteada sobre la reordenacion automatica que queria conseguir en un libro excel algo grande
saludos
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar