Excel - Producto condicional

   
Vista:

Producto condicional

Publicado por Montse moontxec@gmail.com (2 intervenciones) el 21/08/2012 09:35:51
Hola,

necesitaria una formula que multiplicara el valor de la columna "A" con el valor de la columna "B" solo si cumple una condicion. Seria un tipo como "sumar.si.conjunto", pero en lugar de sumar los valores una misma columna que cumple con el condicional, sería el producto de una columna con otra.

¿Me podéis ayudar?

Muchas gracias!, Saludos,
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder

Producto condicional

Publicado por Hocal (3 intervenciones) el 21/08/2012 13:40:48
Hola,

Podrías utilizar la siguiente fórmula: =SI(C1>5;A1*B1;0)

En este ejemplo la condición se encuentra en la columna C, si su valor es superior a 5 realizará la multiplicación de los valores en las columnas A y B. Si la condición no se cumple, el resultado de la operación en 0.

¡Espero que la respuesta te sea de utilidad!
Sígueme en mi blog: http://hocalsolutions.blogspot.com.es/
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

Producto condicional

Publicado por jcs (494 intervenciones) el 22/08/2012 08:36:21
Muy buenas.

Yo utilizaríaalgo así como la siguiente fórmula:
=SUMAPRODUCTO((A1:A10>4)*(B1:B10)*(A1:A10))

Como ves tienes 3 tres factores que se multiplican. El primero de ellos lo que te proporciona es un 1 cuando se cumple la condición, y un 0, en caso contrario. Con ello, lo que se obtiene es la suma de 10 productos, de los cuales, aquellos que no cumplen la condición, son cero.

Un saludo. Juanjo.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

Producto condicional

Publicado por Montse (2 intervenciones) el 27/08/2012 10:38:20
Hola,

gracias por la ayuda, pero en este caso concreto no me sirve ya que la condiciónque le quiero dar es en formato texto y no número. Pongo un ejemplo:

A B C
Juan 1 25%
Juan 2 35%
Pepe 3 15%
Maria 4 20%
Maria 5 5%

Queria saber la suma del producto de BxC solo para los regsitros de "Maria".

Gracias,

Un saludo
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

Producto condicional

Publicado por Esteban egcyan@gmail.com (1 intervención) el 04/08/2013 08:04:27
Mm yo lo hice con un condicional simple, mira.

=SI(A1="maria";B1*C1;0) Es decir, si la columna A dice maría, entonces multiplique la columna B con la C. No sé si así era.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

Producto condicional

Publicado por Natalia (2 intervenciones) el 19/10/2016 20:37:12
Hola:
Como haría, para que me tomara el valor de la formula, si reemplazo "maria", en la formula anterior por diferentes fechas, es decir si en la celda que deseo tomar para obtener el resultado de un producto, tengo una fecha o no.
Es decir que en una celda x, obtengo un valor de una multiplicación entre 2 valores conocidos y constantes, si en otra columna aparece una fecha.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar
Imágen de perfil de wordexperto.com

Producto condicional

Publicado por wordexperto.com (486 intervenciones) el 20/10/2016 06:28:25
Hola Natalia:
La función Si no reconoce las fechas como tales. Por tanto tienes que colocarlas en otra celda y hacer referencia a esa celda en la función. La otra solución es anidar la función fecha. Ejemplo: =si(a1<fecha(2016;10;20);b1*c1;"")
https://wordexperto.com/blog/
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

Producto condicional

Publicado por Natalia (2 intervenciones) el 20/10/2016 12:45:16
Gracias por responder a mi consulta.

Y si en la formula de producto condicional, en lugar de un texto, quiero hacer referencia a un color u otro?

O sea, que en la celda x, se muestre el resultado de producto de dos valores conocidos y constantes, si en otra columna aparece uno de los 3 colores que tengo de referencia.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar
Imágen de perfil de wordexperto.com

Producto condicional

Publicado por wordexperto.com (486 intervenciones) el 20/10/2016 15:16:01
Supongo que se podrá hacer con código. Pero la cuestión es a la inversa. Las celdas se colorean según su valor aplicando una fórmula. Por consiguiente es esa fórmula (sus condiciones) las que tienes que poner en la función SI.
https://wordexperto.com/blog/
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

Producto condicional

Publicado por LOLA (2 intervenciones) el 18/11/2016 11:42:47
Buenos días.

Una consulta respecto a su respuesta. si quiero hacer esa misma fórmula pero para que me lea varias celdas y en el caso de que sea maria me sume esas multiplicaciones, como sería?

He probado con =SI(A1:A8="maria";B1:B8*C1:C8;"0")
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar
Imágen de perfil de wordexperto.com

Producto condicional

Publicado por wordexperto.com (486 intervenciones) el 18/11/2016 12:12:59
La función si no te sirve para rangos. Para usarla deberías comparar fila a fila en una columna auxiliar y luego sumar. Para hacerlo de una vez, tienes que usar: =SUMAPRODUCTO((A1:A8="María")*B1:B8*C1:C8)
https://wordexperto.com/blog/
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

Producto condicional

Publicado por LOLA (2 intervenciones) el 18/11/2016 13:28:27
Muchísimas gracias!!
Ya funciona.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

Producto condicional

Publicado por RoDiN mark.rodin@gmail.com (2 intervenciones) el 30/08/2016 19:17:00
Buen día:

Retomo este hilo para no abrir un nuevo tema. Mi duda ha sido resuelta gracias a este hilo, manejo una tabla de precios con precios de mayoreo y menudeo y requería poder manejar precio en base a cantidad solicitada por el cliente. Mi formula final ha quedado de la siguiente manera (mi precio de mayoreo es de 10 piezas mínimo)

=SI(G25>=10,G25*D25,C25*G25)
Dónde
Columna G= cantidad de producto solicitada
Columna D= precio de mayoreo
Columna C= precio de menudeo

Ahora, algunos productos no aplican mayoreo, por lo que en la columna D (que es la que tiene el precio de mayoreo) se aplica la leyenda "N/A" ¿Cómo podría modificar mi formula a fin de que cuando en la columna D aparezca esta leyenda, se omita el precio de mayoreo y sólo me entregue el producto del costo de menudeo?

Espero explicarme, desde ya, gracias por la atención
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar
Imágen de perfil de wordexperto.com

Producto condicional

Publicado por wordexperto.com (486 intervenciones) el 30/08/2016 22:10:57
Hola RoDIN:
Debes anidar en la fórmula en si,error: =SI.ERROR(SI(G25>9;D25*G25;G25*C25);G25*C25)
Mi separador es el punto y coma, cámbialo por la coma, si es el tuyo.
https://wordexperto.com/blog/
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
1
Comentar

Producto condicional

Publicado por RoDiN (2 intervenciones) el 13/09/2016 18:24:17
Muchísimas gracias, me ha funcionado perfecto, tal y como dices.

Ahora, tengo otra duda para otro condicional.

En una celda (pongamos G3) tengo lista desplegable de Facturar (si) (no)

¿Cómo podría hacer para que en la celda de monto de IVA seleccione aplicar o no IVA? Imaginemos que las celdas son así

F10 subtotal
F11 IVA
F12 TOTAL

Lo estuve intentado, pero manda error la formula constante. No se que escribí mal, la idea es que si en G3 tenemos SI, F11 muestre =F10 * .16 y F12 =F10 +F11, si en G3 tenemos NO, entonces F11 = N/A y F12 =F10
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar
Imágen de perfil de wordexperto.com

Producto condicional

Publicado por wordexperto.com (486 intervenciones) el 13/09/2016 19:04:16
Creo que tienes la estructura mal. subtotal, iva y total deben ser columnas, no filas.
En cualquier caso, lo puedes hacer del tirón, en un solo paso.
Con tu estructura: =si(g3="si";f10*1,16;f10)
https://wordexperto.com/blog/
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
1
Comentar