Excel - Sumaproducto con condiciones

   
Vista:

Sumaproducto con condiciones

Publicado por Alberto (12 intervenciones) el 11/03/2013 15:25:42
Estimados:Necesito ayuda,

Sí : SUMAPRODUCTO((B1:B1000="h")*(C1:C1000="HOJAS"))
me surge una dificultad, a cada uno de los resultados de la SUMAPRODUCTO lo tengo que multiplicar por un valor que se encuentra en la celda A, siendo (A1:A1000), o sea, por cada valor de A cuando encuentra un valor en C. Los valores de A son aleatorios (corresponden a cantidades circunstanciales).
A B C
Cant. Hoja Código
14 H B14010
2 H B14010
etc,
Resumiendo: SUMAPRODUCTO((B1:B1000="h")*(C1:C1000="HOJAS")*(A:A1000=¿?) . Ya que los valores de A varían en cada línea.
Agradeceré si alguien me puede dar una mano.

Saludos.
Alberto
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder

Sumaproducto con condiciones

Publicado por jcs (494 intervenciones) el 11/03/2013 22:12:16
Muy buenas.

Casi lo consigues. Simplemente es un producto, la A no lle condiciones.

=SUMAPRODUCTO((B1:B1000="h")*(C1:C1000="HOJAS")*(A1:A1000))

Un saludo. Juanjo.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

Sumaproducto con condiciones

Publicado por Alberto (12 intervenciones) el 12/03/2013 12:21:47
Gracias Juanjo una vez más!
Te comento que lo había intentado, pero me da como resultado #¡VALOR!.

Alberto
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

Sumaproducto con condiciones

Publicado por jcs (494 intervenciones) el 12/03/2013 13:33:02
Revisa los valores que tienes en la columna A, tienen que tener un número o estar en blanco, pero nunca texto.

Un saluod. Juanjo.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar