Excel - Comparar celda de texto con vectro de texto

   
Vista:

Comparar celda de texto con vectro de texto

Publicado por Miguel alexis (5 intervenciones) el 08/07/2013 17:56:52
estimados , necesito LA FUNSION comparar una ceda ejemplo a1 con vector de datos b1;b15 y si es igual algun dato arroje una dato "SI " o "NO"


ejemplo

A1 = 130E/REN/003


B1=102/PTE/007
103/PE/006
103/PE/011
103/PE/012
103/PE/013
104/MAN/001
104/MAN/002
104/PTE/015
104/PTE/025
"130E/REN/003
"
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder

Comparar celda de texto con vectro de texto

Publicado por nolberto (8 intervenciones) el 08/07/2013 19:57:30
Esta es una opcion.
=SI(BUSCARV(A1,$B$1:$B$6,1,FALSO)=A1,"SI","NO")

suerte
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

Comparar celda de texto con vectro de texto

Publicado por jcs (494 intervenciones) el 09/07/2013 08:58:42
Muy buenas.

Tu idea, Nolberto, es correcta, sin embargo, no funciona para el caso de que no se encuentre el resultado. El resultado que tú pretendes es "NO", y lo que se obtendría sería un "#N/A". Mi propuesta sería esta:
=SI(ESERROR(BUSCARV(A1;$B$1:$B$6;1;FALSO));"NO";"SI")

En función de la configuración que tengas, tendrías que utilizar "," (coma) en lugar de ";" (punto y coma).

Un saludo. Juanjo.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

Comparar celda de texto con vectro de texto

Publicado por Cacho (44 intervenciones) el 09/07/2013 22:30:21
Hola! Miguel (Nolberto y jcs)
También podrías implementar:

=SI(CONTAR.SI(B1:B15; A1); "Si"; "No")

Saludos, Cacho R.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

Comparar celda de texto con vectro de texto

Publicado por jcs (494 intervenciones) el 10/07/2013 08:48:25
Fenomenal, Cacho. Viva la sencillez.
Mismos resultados con menos recursos, eso es eficiencia.

Un saludo. Juanjo.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar