Excel - Fx encontrar 2 palabras dentro de celdas

   
Vista:

Fx encontrar 2 palabras dentro de celdas

Publicado por Sebastian (17 intervenciones) el 07/08/2013 12:50:31
Buenos dias.

Necesito de su ayuda con algo que no logro hacer que funcione.

En la columna A tengo productos, y en la columna B me debe de dar como resultado CORRECTO si dentro del texto de la celda contiene "BOLSA" o "BASE", e incorrecto si no tiene ninguna de estas dos palabras.

A B
BASE DE CONCRETO CORRECTO
BOLSA DE CEMENTO CORRECTO
FIERROS USADOS INCORRECTO
PAPEL PARA CEMENTO INCORRECTO
CLAVOS PARA CEMENTO INCORRECTO


Este codigo me resulta excelente solo con la palabra "BASE"

=SI(ESNUMERO(ENCONTRAR("BASE",B2))," Correcto", " Incorrecto")

Y en ste otro codigo quize anidar la otra palabra "BOLSA"; pero no me da el rsultado que necesito.

=SI(ESNUMERO(O((ENCONTRAR("BOLSA",B2)),(ENCONTRAR("BASE",B2))))," Correcto", " Incorrecto")

Por favor, que estoy haciendo mal, o quizas haya otra forma ...

Gracias.
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder

Fx encontrar 2 palabras dentro de celdas

Publicado por Mauricio (4 intervenciones) el 07/08/2013 15:53:10
Hola,

algo así debe funcionar:

=SI(CONTAR(HALLAR({"BASE";"BOLSA"};B5));"CORRECTO";"INCORRECTO")
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

Fx encontrar 2 palabras dentro de celdas

Publicado por Sebastian (17 intervenciones) el 08/08/2013 09:15:03
Excelente.

Este código me permite hasta poder ingresar más palabras.

Gracias por el apoyo.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar