Excel - Rellenar celdas en cero a la izquierda

   
Vista:

Rellenar celdas en cero a la izquierda

Publicado por Dario (88 intervenciones) el 10/04/2014 22:51:42
Tengo en la Celda A1 escrito el Nº 2 y en la celda B1 quisiera que se traslade el importe de la celda A1 pero que se complete con ceros a la izquierda hasta llegar a tener un total de 4 cifras.

Ejemplo:
celda A1 = 2
Celda B = 0002

Lo que hago en la celda B1 es ir a Formato de Celdas - Numero - Personalizada y en Tipo le escribo 4 ceros. La cuestion esta en que si escribo el nº 2 en la celda B1 me pone como resultado 0002, pero cuando escribo en la celda B1 la formula =A1 el resultado es 2 y no 0002.
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder
Imágen de perfil de JuanC

Rellenar celdas en cero a la izquierda

Publicado por JuanC juanc2942@gmail.com (1052 intervenciones) el 11/04/2014 00:26:06
prueba con la siguiente fórmula...

1
=SI(LARGO(A1)<=4;REPETIR("0"; 4-LARGO(A1)) & A1;A1)

Saludos, desde Baires, JuanC
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

Rellenar celdas en cero a la <span class="ohp00f9" id="ohp00f9_6">izquierda</span>

Publicado por Dario (88 intervenciones) el 11/04/2014 01:41:37
Muchicimas gracias. Te pido un ultimo favor, fijate el nuevo mje q envie
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar