Excel - Filtrar numeros

   
Vista:

Filtrar numeros

Publicado por Dario (88 intervenciones) el 08/05/2014 19:33:56
Paso el siguiente ejemplo
Columna / Dato Ingresado
A1: 1
A2: 1
A3: 2
A4: 19
A5: 2
A6: 3

B1: 15
B2: 112
B3: 18
B4: 7
B5: 45
B6: 8

Necesito hacer que mediante una Macro se pueda sumar todo de la columna B que correspondan al mismo numero de la columna A.

Ejemplo: si tomo el Nº 2 de la columna A el resultado de la suma sera: 63
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder
Imágen de perfil de Antoni Masana

Filtrar numeros

Publicado por Antoni Masana (268 intervenciones) el 09/05/2014 07:59:56
No se entiende

¿De donde sale la suma de 62 y de donde tomas el Nº 2?
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

Filtrar numeros

Publicado por Juanjo (494 intervenciones) el 09/05/2014 08:31:55
Muy buenas.

Puedes que utilizar la función SUMAR.SI de este forma:
=SUMAR.SI(A:A;2;B:B)

Si el valor que deseas calcular lo tienes en una celda, por ejemplo C1:
=SUMAR.SI(A:A;C1;B:B)

Un saludo. Juanjo.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar