Excel - Contar carácteres en varias celdas rodeadas de texto

   
Vista:

Contar carácteres en varias celdas rodeadas de texto

Publicado por Pauers (1 intervención) el 06/12/2014 09:38:57
Hola. Llevo horas buscando y no encuentro la solución a esto, así que he decidido plantear la pregunta.

Tengo un rango de celdas, digamos A1:A3 y tengo las siguientes palabras
aaaholaaa
bbbholabb
cccholacc
Lo que me interesa es contar cuantas veces salen los carácteres hola. Es decir, una fórmula que me tendría que dar 3 como resultado.

He probado combinaciones con Contar y Largo pero no hay manera...
Alguien me puede ayudar?
Gracias
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder
Imágen de perfil de LaO

Contar carácteres en varias celdas rodeadas de texto

Publicado por LaO (67 intervenciones) el 06/12/2014 15:10:16
Hola Pauers,

Bien, hay dos formas de hacerlo.

01- Coloca en las celdas B1,B2,B3 la fórmula:
---------------------------------------------------------------->
=SI(ENCONTRAR("hola";A1;1)>0;1;0)
=SI(ENCONTRAR("hola";A2;1)>0;1;0)
=SI(ENCONTRAR("hola";A3;1)>0;1;0)

Al final sumas el resultado de la columna B lo cual te dará tres.

02- Creas una UDF (Función de usuario). Para esto coloca la siguiente rutina en un módulo y luego en la celda donde desees obtener el resultado asignas la fórmula =fnTextCounter($A$1:$A$3;"hola") :

------------------------------------------------------------------->

Function fnTextCounter(ByVal Rango_Texto As Range, Par_Texto) As Long

Dim objCell
Dim i As Long
Dim n As Integer

For Each objCell In Rango_Texto

n = InStr(1, objCell.Value, Par_Texto, vbTextCompare)

If n > 0 Then i = i + 1

Next objCell

fnTextCounter = i

End Function


Un saludo,
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar