Excel - Transformar valor

   
Vista:

Transformar valor

Publicado por Fernando fernandosrusso@gmail.com (3 intervenciones) el 22/12/2014 14:17:53
Tengo un problema, necesito de un dato de excel modificarlo por formula para que quede de otra forma.

Ejemplo:

Tengo este dato en una celda (de 6 dígitos):

123456

Y yo necesito que se agrande, y se repitan al final los últimos cuatro números.
Quedando así: (de 10 dígitos)

1234563456

Esto se aplicaría a todos los datos de una columna

Muchas gracias!
Fernando
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder
Imágen de perfil de LaO

Transformar valor

Publicado por LaO (67 intervenciones) el 22/12/2014 15:44:26
Hola Fernando,

Asumiento que tu dato de ejemplo está en la celda A1, coloca donde quieras el resultado la siguiente fórmula:

=A1&DERECHA(A1;4)

Con esto lograrás lo que deseas.

Un saludo,
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

Transformar valor

Publicado por Fernando fernandosrusso@gmail.com (3 intervenciones) el 22/12/2014 15:54:45
Gracias LaO.

Esta solucion me funciona si no hay ceros.
por ejemplo:
123456 lo pasa correctamente a 1234563456
pero:
012345 lo pasa 123452345 sin contar el cero.y deberia ser:0123452345
ni que hablar si es:
000083 lo pasa 8383 y deberia ser 0000830083

No se como solucionarlo.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar
Imágen de perfil de LaO

Transformar valor

Publicado por LaO (67 intervenciones) el 22/12/2014 16:09:07
Hola Fernando,

Reemplaza la fórmula por la siguiente:

=TEXTO(A1;"000000")&DERECHA(TEXTO(A1;"000000");4)

Debes solucionar el problema con este enfoque. Comentas.

Un saludo,
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
1
Comentar

Transformar valor

Publicado por Fernando (3 intervenciones) el 23/12/2014 15:32:14
Funciona perfecto.
muchas gracias LaO!
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar