Excel - Mostrar ocupación entre fechas por día

   
Vista:

Mostrar ocupación entre fechas por día

Publicado por elpopi (2 intervenciones) el 26/02/2015 19:08:19
Hola,

A ver si alguien me puede echar una mano, que no soy capaz de dar con una solución:

Tengo 3 columnas con las fechas de entrada, salida y noches de una estancia en un hotel. Me gustaría obtener un cuadro que muestre la ocupación por días.

Tengo 3 columnas:
Fecha entrada --- Fecha salida --- noches
04/06 --- 06/06 --- 2
02/06 --- 06/06 --- 4

y me gustaría que se generara un cuadro así (El rango de fechas es concreto, las fechas son solo de 02 al 08 del 6)

02/06 --- 03/06 --- 04/06 --- 05/06 --- 06/06 --- 07/06 --- 08/06
0 --- 0 --- 1 --- 1 --- 0 --- 0 --- 0
1 --- 1 --- 1 --- 1 --- 0 --- 0 --- 0

Esto es un ejemplo hecho a mano
Untitled-1
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder

Mostrar ocupación entre fechas por día

Publicado por MMan (6 intervenciones) el 26/02/2015 19:29:42
en ocupacion por dia... pones una condicion...
si fecha >= entrada Y fecha<=salida
pone un 1
y si no... pone un 0 o ""

suponiendo que...
B3 = Entrada
C3 = Salida
D3 = Noches
F2 = 02/06 (Fechas ocupacion x dias)

F3 = formulas
=SI(Y(F$2>=$B3,F$2<$C3),1,"")


77b5dc1603efd6177941f1bd097db4c1
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
1
Comentar

Mostrar ocupación entre fechas por día

Publicado por el (2 intervenciones) el 27/02/2015 10:08:45
muchas gracias, con tu ayuda lo he solucionado
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

Mostrar ocupación entre fechas por día

Publicado por Khristian (7 intervenciones) el 26/02/2015 19:44:16
Según lo que entendí....

Quieres controlar las noches, y representar visualmente la ocupación por días.

Hice un ejercicio como ejemplo, basado como arriendo de cabañas.

Te adjunto una captura.
https://www.dropbox.com/s/ru10858uabrfrv7/D-N%20Caba%C3%B1as.JPG?dl=0

Te adjunto el xls
https://www.dropbox.com/s/97rkirslzzo7jgp/D-N%20Caba%C3%B1as.xls?dl=0

Las celdas de color, tienen formulas y hacen los cálculos de noche y días.

Si quisieras limitar a que solo se muestren hasta la fecha actual, hay que modificar la formula de los días, definiendo previamente si la fecha de salida en mayor a la fecha actual.

Espero te sirva.

Saludos
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
1
Comentar