Excel - redondear decimales a entero o medio

   
Vista:

redondear decimales a entero o medio

Publicado por Marina marinavidalmussarra@gmail.com (1 intervención) el 27/04/2015 12:46:26
BUENOS DÍAS,

SE TRATA DE REDONDEAR LOS DECIMALES QUE NO LLEGAN A MEDIO (EJ: 7,45) AL NUMERO ENTERO (EJ:7,00)
Y LOS DECIMALES QUE PASAN DE MEDIO (EJ: 7,87) A MEDIO (EJ: 7,50).

ENTONCES EL 7,48 RE REDONDEA EN 7,00. PORQUE NO LLEGA A MEDIO.

GRACIAS!
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder

redondear decimales a entero o medio

Publicado por Khristtian (77 intervenciones) el 27/04/2015 16:52:30
Una función para redondear... mmmm mmmm

Podría llamarse.... REDONDEAR.........

Prueba esto:

=REDONDEAR(7,4;0)
=REDONDEAR(7,5;0)


Usa (;) o (,) según tu separador de listas.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

redondear decimales a entero o medio

Publicado por Legarda (68 intervenciones) el 27/04/2015 23:19:35
Guárdese su sarcasmo sino sabe leer el dice redondear decimales LEA BIEN LA PREGUNTA
no conozco algo en excel que haga lo que pides
Pero puedes hacer lo siguiente
Crea un modulo y copia este código

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
Public Function Redondear_Dec(Numero As Double, SeparadorDec As String) As Double
 
Dim Media, Posicion As Integer
 
Numero = Round(Numero, 2)
Posicion = InStr(Numero, SeparadorDec)
Media = Mid(Numero, Posicion + 1, Posicion + 1)
 
If Media < 50 Then
Numero = Left(Numero, Posicion)
Else
Numero = Left(Numero, Posicion)
Numero = Numero & ",50"
End If
 
Redondear_Dec = Numero
 
End Function


cierra el código y ahora busca la función en la formulas definidas por el usuario
allí encontraras esta función, y esto actua como una formula normal
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

redondear decimales a entero o medio

Publicado por Juanjo (494 intervenciones) el 28/04/2015 08:19:59
Muy buenas.

Puedes utilizar la función REDONDEAR.MENOS, o simplemente ENTERO, lo único es que al querer el medio, hay que utilizar una pequeña transformación. Seguramente te servirá esto:

=ENTERO(A1*2)/2

Un saludo. Juanjo.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar