Excel - CONDICIONALES

   
Vista:

CONDICIONALES

Publicado por DAREMAR (4 intervenciones) el 23/09/2015 21:32:49
Buenas Tardes,

Tengo esta duda, estoy escribiendo esta formula y aparece error en valor !#valor! quiero saber que error tengo:

1
=SI(Y(B279>=0;B279<=999);(B279*2,1));SI(Y(B279>=1000;B279<=1999);(B279*1,95));SI(Y(B279>=2000;B279<=2999);(B279*1,8))

Agradezco su ayuda
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder

CONDICIONALES

Publicado por GMG (105 intervenciones) el 24/09/2015 13:23:36
Tienes que poner el siguiente si, dentro del anterior.

Así:

=SI(Y(B279>=0;B279<=999);(B279*2,1);SI(Y(B279>=1000;B279<=1999);(B279*1,95);SI(Y(B279>=2000;B279<=2999);(B279*1,8))))

El problema, por lo que he visto de tu consulta anterior, es que se te van a ir anidando demasiadas condiciones, y va a ser muy fácil que te equivoques.

Si lo quieres hacer con fórmulas, te sugiero que utilices algo así:

=SI(Y(B279>=0;B279<=999);2,1;1)*SI(Y(B279>=1000;B279<=1999);1,95;1)*SI(Y(B279>=2000;B279<=2999);1,8;1)*B279

Si se cumple la condición devuelves el valor a multiplicar, sino devuelve 1, lo multiplicas todo por el valor de la celda concreta, creo que así te será más fácil que anidando condicionales.

Saludos!
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar