Excel - unir dos funciones buscarv con un or

   
Vista:

unir dos funciones buscarv con un or

Publicado por CARLOS (1 intervención) el 06/11/2015 04:42:37
=SI(F185<>"";BUSCARV(A185;'Base Compras'!A2:X29903;4;FALSO))
=SI(H185<>"";BUSCARV(C185;'Base Compras'!C2:X29903;2;FALSO))

Si F185 ESTA EN BLANCO QUE PERMITA INGRESAR EL DATO EN H185 ,, el resultado va en D185


Gracias al que me pueda ayudar..
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder

unir dos funciones buscarv con un or

Publicado por Martha (270 intervenciones) el 07/11/2015 20:28:09
No se entiende qué es lo que necesitas.

La función OR es una función lógica que devuelve VERDADERO cuando uno de sus argumentos es verdadero.

No usas bien las funciones SI. Una función SI tiene tres partes: Una prueba lógica (que solo puede ser verdadera o falsa), un resultado para cuando es verdadera y un resultado para cuando es falsa.

Poner F185<>"" es tan ambiguo que te dará errores.

Yo uso lógica inversa. En tu caso sería SI(F185 = ""; (nada); (lo que quiero que haga cuando es falso, que es tu caso))

Si describes con palabras qué es lo que necesitas (no hagas referencia a la fila 185) entonces te podremos ayudar.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar