Excel - Fila de ubicación de un dato

   
Vista:

Fila de ubicación de un dato

Publicado por Gustavo ggarassino@cartellone.com.ar (1 intervención) el 26/02/2016 20:51:34
Hola.
Más allá que se puede usar FILTROS para el problema que presento, me interesa saber la solución a lo siguiente.
Tengo la columna B3:B5000 con números enteros desordenados.
Quiero saber si un número determinado está en la columna y en qué fila se encuentra.
En celda C1 coloco el número que quiero saber si existe.
En C2 coloco la fórmula =SI(ESERROR(BUSCARV(C1;B3:B5000;1;FALSO));"No existe";FILA(BUSCARV(C1:B3:B5000;1;FALSO))).
Lamentablemente sale el aviso de Error en la fórmula, pero no me doy cuenta dónde puede estar, ya que la función FILA(ref) debería dar el dato a partir del resultado del BUSCARV.
Tal vez alguien pueda orientarme qué estoy haciendo mal o cómo se puede saber esa fila.
Gracias.

Gustavo
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder
Imágen de perfil de Miltinho

Fila de ubicación de un dato

Publicado por Miltinho miguicastro@hotmail.com (14 intervenciones) el 26/02/2016 22:11:12
Hola Gustavo...
La función FILA requiere un rango de celda específico para que devuelva el número de la fila, y con BuscarV sólo le pasa el valor que encontró. Adicionalmente, te faltaba completar la prueba lógica del SI.

Por lo anterior, mi solución es:
1
=SI(ESERROR(BUSCARV(C1;B3:B5000;1;0))=VERDADERO;"No existe";COINCIDIR(C1;B3:B5000;0)+2)

Miltinho - ALS

https://www.youtube.com/channel/UCen9plVtEaEMopzWdXb9lzw
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar
Imágen de perfil de wordexperto.com

Fila de ubicación de un dato

Publicado por wordexperto.com (496 intervenciones) el 27/02/2016 09:00:43
Hola Gustavo:
Simplemente COINCIDIR(C1;B3:B5000;0)+2 te da la fila.
http://wordexperto.com/
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar