Utilizamos cookies propias y de terceros para mejorar la experiencia de navegación, y ofrecer contenidos y publicidad de interés.
Al continuar con la navegación entendemos que se acepta nuestra política de cookies.
Iniciar sesión Cerrar
Correo:
Contraseña:
Entrar
Recordar sesión en este navegador
Iniciar sesiónIniciar sesiónCrear cuentaCrear cuenta

Excel - hallar el signo zodiacal

  Imprimir  
Vista:
Me gusta: Está pregunta es útil y esta clara
0
No me gusta: Está pregunta no esta clara o no es útil
 
Asunto:

hallar el signo zodiacal

Autor:cbic (26 intervenciones)
Fecha:25/06/2006 00:14:25
Hola a todos, quisiera q me colaboren con esta pregunta
si en c1=14/04/06 en d1=aries
en c1 ira cualquier fecha y
d1 hallara a que signo zodiacal pertenece
gracias de antemano por la rpta.
Responder
información
Otras secciones de LWP con contenido similar...
Me gusta: Está respuesta es útil y esta clara
0
No me gusta: Está respuesta no esta clara o no es útil
 
Asunto:

RE:hallar el signo zodiacal

Autor:LOSCAR (21 intervenciones)
Fecha:29/06/2006 23:14:33
ESTO LO RESPONDI EN OTRO POST... ESPERO SEA LO QUE NECESITES.

Buen día… una solución poco elegante es la siguiente, pero no tengo mucho tiempo, además creo que con esta idea será poco lo que tengas que modificar… además que lo hice de esta manera, porque he visto que muchos tienen problemas con los IF (SI) anidados, y creo que esta formula vendrá a quitar muchos dolores de cabeza.

Supondremos que en el entorno de Excel tienes lo siguiente.

A B C
21-Mar 20-Abr ARIES
21-Abr 21-May TAURO
22-May 21-Jun GÉMINIS
22-Jun 22-Jul CÁNCER
23-Jul 22-Ago LEO
23-Ago 23-Sep VIRGO
24-Sep 23-Oct LIBRA
24-Oct 22-Nov ESCORPIO
23-Nov 21-Dic SAGITARIO
22-Dic 20-Ene CAPRICORNIO
21-Ene 20-Feb ACUARIO
21-Feb 20-Mar PISIS

En la columna E1 ingresas la fecha… y en la columna E2 ingresas la siguiente formula: =SI(Y(E1>=A1,E1<=B1),C1,"")&SI(Y(E1>=A2,E1<=B2),C2,"")&SI(Y(E1>=A3,E1<=B3),C3,"")&SI(Y(E1>=A4,E1<=B4),C4,"")&SI(Y(E1>=A5,E1<=B5),C5,"")&SI(Y(E1>=A6,E1<=B6),C6,"")&SI(Y(E1>=A7,E1<=B7),C7,"")&SI(Y(E1>=A8,E1<=B8),C8,"")&SI(Y(E1>=A9,E1<=B9),C9,"")&SI(Y(E1>=A10,E1<=B10),C10,"")&SI(Y(E1>=A11,E1<=B11),C11,"")&SI(Y(E1>=A12,E1<=B12),C12,"")

El problema que te indique es con el signo de CAPRICORNIO… debido a que inicia en diciembre y termina en enero… es decir pasa de un año a otro, simplemente con agregarle una pequeña condición funcionaría bien… lo dejo a tu disposición para que lo termines, pero si no lo logras estoy a la orden… lo hago para que practiques.

Cada condición dice: Si E1 es mayor o igual que A1 Y E1 es menor o igual a B1, entonces coloque C1 (o sea el nombre del signo) de lo contrario coloca un espacio en blanco (o sea nada).
Comentar