Utilizamos cookies propias y de terceros para mejorar la experiencia de navegación, y ofrecer contenidos y publicidad de interés.
Al continuar con la navegación entendemos que se acepta nuestra política de cookies.
Iniciar sesión Cerrar
Correo:
Contraseña:
Entrar
Recordar sesión en este navegador
Crear cuenta

Excel - CONTAR FECHAS CON LA FUNCION CONTAR.SI

Vista:
Me gusta: Está pregunta es útil y esta clara
0
No me gusta: Está pregunta no esta clara o no es útil
 
Asunto:CONTAR FECHAS CON LA FUNCION CONTAR.SI
Autor:javier (5 intervenciones)
Fecha:04/03/2007 12:25:22
Hola, mi pregunta es la sIguiente:
Estoy intentando contar el nº de veces que ocurre una incidencia en intervalos de una hora
y como entrada tengo una hoja excel con una fila como la que se muestra debajo (LA FILA A) (normalmente de unas 20 mil columnas), es decir necesito que en otra hoja obtener el nº de veces que se produjo la incidencia en una hora determinada por ejemplo de 10 a 11 (en general de x horas a x+1 hora) , (LOS MESES DIAS Y AÑOS NO ME INTERSESA , LOS MINUTOS Y SEGUNDO TAMPOCO, SOLAMENTE LA HORA)

A
03/04/2007 08:33:51
03/04/2007 08:18:59
03/04/2007 08:17:09
03/04/2007 08:17:08
03/04/2007 08:17:07
04/04/2007 10:17:06
04/04/2007 11:17:06
04/04/2007 11:47:06

Para el ejemplo con una hoja como la que se muestra arriba el resultado debe ser el siguiente
B C
de 8 a 9 se han producido 5
de 9 a 10 se han producido 0
de 10 a 11 se han producido 1
de 11 a 12 se han producido 2

y para ello utilizo la funcion de excel 'contar.si' por ejemplo para contar de 8 a 9

=CONTAR.SI(A:A;"*08:??:??") -----ESTO NO ME FUNCIONA
=CONTAR.SI(A:A;"*08:??:??*") -----TAMPOCO NO FUNCIONA
=CONTAR.SI(A:A;"08:??:??") -----TAMPOCO NO FUNCIONA
=CONTAR.SI(A:A;"??/??/?? 08:??:??") -------TAMPOCO NO FUNCIONA


ES EXTRAÑO QUE NO LO CUENTE PORQUE SI AÑADO A LA FECHA UN .0 SI QUE LO CUENTA
EJEMPLO:
A
04/04/2007 11:47:06.0 (PUEDE SE TAMBIEN .CUALQUIER NIUMERO)
Y UTILIZO LA FUNCION
=CONTAR.SI(A:A;"*08:??:??*") --- AHORA SI QUE DEVUELVE EL VALOR 5

HE INTENTADO CON LA FUNCION CONCATENAR AÑADIRLE UN '0' PERO NO LO AÑADE
CONVIERTE LA
CREO QUE ES POR EL FORMATO DE LA CELDAS QUE SON FECHAS

EN FIN SI ME PODEIS ECHAR UNA MANO , MUCHAS GRACIAS
Responder Subir
información
Otras secciones de LWP con contenido similar...
Me gusta: Está respuesta es útil y esta clara
0
No me gusta: Está respuesta no esta clara o no es útil
 
Asunto:RE:CONTAR FECHAS CON LA FUNCION CONTAR.SI
Autor:JuanC (792 intervenciones)
Fecha:04/03/2007 12:46:23
Puede hacerse con una fórmula matricial

{=SUMA(SI(HORA(A1:A20000)=x;1;0))}

x es la hora que interesa contar (8, 9, 10, 11, ...)
A1:A20000 es el rango que contiene los datos

Saludos desde Baires, JuanC
Comentar Subir
Me gusta: Está respuesta es útil y esta clara
0
No me gusta: Está respuesta no esta clara o no es útil
 
Asunto:RE:CONTAR FECHAS CON LA FUNCION CONTAR.SI
Autor:javier (5 intervenciones)
Fecha:04/03/2007 13:29:09
Funciona!!!!!!!! , muchas gracias por la rapidez
desde (Malaga) España
Comentar Subir
Me gusta: Está respuesta es útil y esta clara
0
No me gusta: Está respuesta no esta clara o no es útil
 
Asunto:RE:CONTAR FECHAS CON LA FUNCION CONTAR.SI
Autor:PEDRO LUIS CAMARGO (13 intervenciones)
Fecha:06/03/2007 03:31:44
JAVERIEN QUE PENA CON USTED
PODRIA ENVIARME UN ARCHIVO CON SU EJEMPLO QUE A MI NO ME FUNCIONA
MUCHAS GRACIAS
Comentar Subir
Me gusta: Está respuesta es útil y esta clara
0
No me gusta: Está respuesta no esta clara o no es útil
 
Asunto:RE:CONTAR FECHAS CON LA FUNCION CONTAR.SI
Autor:lupe (2 intervenciones)
Fecha:28/03/2007 01:20:07
Hola amigos
Talvez tengas una solucion al problema que se ha presentado:
tengo dos fechas en diferentes columnas que son los dias que segun una ficha una persona ha asistido para recibir tratamiento se debe contar el 7 y el 12 excepto los domingos o feriados por ejemplo
7 de Febrero de 2004, 12 de Abril de 2004
Con el la funcion dias.lab sale menos dias 46 dias cuando cuentas en el calendario sale 54. Tambien hice otra operacion que es muy tediosa hice una resta de fechas = 65 y sume 1 para que cuente el dia 12 luego reste las fechas los dias festivos contandos en el calendario que son 12) esta ultima operacion es muy tediosa
Conoces algun otro metodo
Saludos

Lupe
Comentar Subir
Me gusta: Está respuesta es útil y esta clara
0
No me gusta: Está respuesta no esta clara o no es útil
 
Asunto:RE:CONTAR FECHAS CON LA FUNCION CONTAR.SI
Autor:Lupe (2 intervenciones)
Fecha:27/03/2007 16:48:46
HOLA JUANC
TAMPOCO ME SALIO, HE INTENTADO CAMBIAR X PORVALORES, ESCRIBIR LA FORMULA PRIMERO Y LUEGO PRESIONAR CTRL,MAYUS y ENTRAR Y TAMPOCO.
EXISTE ALGUN ARTIFICIO O COLUMNA CREADA
SALUDOS
LUPE
Comentar Subir
Me gusta: Está respuesta es útil y esta clara
0
No me gusta: Está respuesta no esta clara o no es útil
 
Asunto:CONTAR FECHAS CON LA FUNCION CONTAR.SI
Autor:Eduardo Lopez (2 intervenciones)
Fecha:03/02/2010 05:00:16
Hola, recientemente se me pidio una funcion en excel que me permita contar las fechas en las celdas inmediatamente cuando se colocan. Un ejemplo mas detallado seria el siguiente.

Proveedores Recibida
1. 6-Ene-10
2. 15-Ene-10
3. No
4. No
. .
. .
n n

Lo que me gustaria saber es como puedo puedo contar las fechas sin incluir a las que tienen en la celda un "NO"??

Eh intentando estas funciones y sigo sin nignun resultado

=CONTAR.SI(Hoja1!F11:F16,<2010/12/31)
=si(<fecha(2012,12,31),1,0)%contar.si(Hoja1!F11:F16,fecha(2012,12,31)).

Por el otro lado tambien quisiera saber una formula que al momento de colocar una fecha se detenga el conteo.

Ejemplo

=hoy()- A2, siendo A2 Ene 13.

Lo que me gustaria saber es una formula que al colocar por ejemplo en A3 Ene 20 se detenga el contador.

Espero una respuesta, de ante mano muchas gracias.
Comentar Subir
Me gusta: Está respuesta es útil y esta clara
0
No me gusta: Está respuesta no esta clara o no es útil
 
Asunto:CONTAR FECHAS CON LA FUNCION CONTAR.SI
Autor:chupetesuazo (1 intervención)
Fecha:27/02/2013 20:05:26
A mi me interesa el mismo ejercicio, pero obtener el mes.

en una casilla tengo por ejemplo 01/02/10 y asi una lista de fechas asi abajo.

Necesito contar cuantos meses ej: Enero hay en la lista

espero que puedan ayudarme
Comentar Subir
Me gusta: Está respuesta es útil y esta clara
0
No me gusta: Está respuesta no esta clara o no es útil
 
Asunto:RE:CONTAR FECHAS CON LA FUNCION CONTAR.SI
Autor:Zuleika (1 intervención)
Fecha:24/04/2013 14:52:07
Hola que pasa cuando quiero sumar el mes de enero1 y coincide con el criterio verdadero que es 1, me da 0, es lo único que me hace falta, para los otros meses si me suma la cantidad.

Necesito de su pronta ayuda
Comentar Subir