Excel - Duda con listado?

   
Vista:

Duda con listado?

Publicado por MARIOSC (1 intervención) el 14/11/2007 11:00:31
Buenas, quisiera saber como se puede hacer una funcion que segun un dato dado, de el resultado segun si esta comprendido en treuno u otro de una lista de datos.

Por ejemplo, tenemos 2 columnas.
DATOS RESULTADO

142 1
285 2
427 3

Asi que segun un numero dado, por ejemplo 280

me de resultado 2 (ya que 280 es menor que 285)

para 140, me de 1 (ya que 140 es menor que 140)

para 285, me de 2 (ya que 285 es igual que 285)

para 286, me de 3 (ya que 286 es menor que 427)

y para 300, me de 3. (ya que 286 es menor que 427)

En vez de tres filas, seria realmente para 20 filas.

Un saludo y gracias
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder

RE:Duda con listado?

Publicado por José Luis (700 intervenciones) el 14/11/2007 14:13:24
Usa un buscarv con el parámetro puesto a 1 y crea una tabla del tipo

_ 0 ______ 1
_142______1
_142,01____2
_285______2
_285,01____3
_427______3

El número de decimales dependerá de los que tengas en tus datos de búsqueda y el cero inicial deberás cambiarlo a un número más pequeño que el menor posible . =BUSCARV(A1;$B$1:$C$6;2;1)

Saludos
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar