Excel - Varias condicinales

   
Vista:

Varias condicinales

Publicado por Carlos lopez (1 intervención) el 21/11/2007 17:52:53
Quisiera saber como hago si tengo un listado con numero en una columna y texto en la siguiente;

1001 texto 1
1002 texto 2
1003 texto 3
etc


al colocar en una celda de otra columna por ejemplo 1002 aparezca la leyenda de texto 2, o si coloco 1001 aparezca texto 1.

agradecere la ayuda

carlos
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder

RE:Varias condicinales

Publicado por Cesar (151 intervenciones) el 21/11/2007 17:58:56
No se cuantos codigos finales tengas texto 1, texto 2 ..... texto 9 o es mucho mas, ya que podrias hacer un buscar simplemente con el codigo ingresado.

No se cuantos codigos (1ra. columna tienes)

Espero haber ayudado al final de todo
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:Varias condicinales

Publicado por Calima (2 intervenciones) el 21/11/2007 18:11:22
No sé si te he entendido bien pero allá voy:

si tienes lo siguiente:

Col 1 Col 2 Col 3 Col 4
1001 texto1
1002 texto2
1003 texto3
1004 texto4

si lo que quieres es que si poniendo en la posición C3,3; el número 1003 te salga en la C4,3; el código texto3 puedes hacer lo siguiente:

introduces en todas las celdas de la Col 4 la siguiente fórmula: (sustituyes col 1 por a, ...)
+si(col 33=1001;texto1;si(col 33=1002;texto2;si(col 33=1003;texto3;si(col 33=1004;texto4;Valor No encontrado))))
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:Varias condicinales

Publicado por Cesar (151 intervenciones) el 21/11/2007 21:26:05
Perdon por decir lo siguiente: esta formula solo funcionaria hasta un determinado rango, ya que sin son mas de 50 datos no funciona, esa era la razon por la que yo pedia cuantos datos erar mas o menos los que tenia que juntar.

Se puede hacer con una tabla de equivalencias
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:Varias condicinales

Publicado por Calima (16 intervenciones) el 22/11/2007 07:58:46
Ah, no sabía:
Entonces lo más sencillo sería una buscarv o una macro muy simplona.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:Varias condicinales

Publicado por jcs (494 intervenciones) el 22/11/2007 08:39:03
Muy buenas,

suponiendo que los datos los tengas en las columnas A y B y que el valor que quieres buscar esté en la celda C1, pon en cualquier otra celda la siguiente fórmula:

=BUSCARV(C1;A:B;2)

Espero que te sirva. Un saludo.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar