Excel - Rango entre fechas

   
Vista:

Rango entre fechas

Publicado por antonio (2 intervenciones) el 22/11/2007 16:08:49
Selección desde-hasta introducidos por el usuario. Lo he probado de dos maneras:
- Primera, que el formato de las celdas “desde, hasta” sea numérica (desde celda E1 y hasta E2),
de ésta manera sale bien
- Segunda, con el formato fecha “desde, hasta” tipo (*14/03/2001) (desde celda D1 hasta D2).
Tanto la columna A como la B, tienen el formato numérico. Y la columna C el mismo formato que la columna D (formato fecha tipo“*14/03/2001”), pero de esta despues de hacerlo de mucha formas no encuentro la forma correcta

A B C D E
10 1 01/01/2007 02/02/2007 2
20 2 02/02/2007 03/02/2007 3
30 3 03/02/2007
40 4 01/03/2007

Primera :
{=SUMAPRODUCTO((B1:B4>=E1)*(B1:B4<=E2)*(A1:A4))} resultado= 50 Ok.
Segunda:
{=SUMAPRODUCTO(C1:C4>(AÑO(D1)*MES(D1)*DIA(D1));C1:C4<(AÑO(D2)*MES(D2)*DIA(D2))*(A1:A4))} resultado = 0

Gracias anticipadas
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder

RE:Rango entre fechas

Publicado por José Luis (700 intervenciones) el 22/11/2007 16:15:25
Sin usar fórmulas matriciales y sólo con SumaProducto aquí tienes varios ejemplos

http://www.xldynamic.com/source/xld.SUMPRODUCT.html

Saludos
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:Rango entre fechas

Publicado por Antonio (2 intervenciones) el 23/11/2007 13:12:14
Gracias José Luis, además de solucionarme el problema, he logrado aclarar varias cosas.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar