Excel - ATASCAO ESTOY "FORMULA"

   
Vista:

ATASCAO ESTOY "FORMULA"

Publicado por JUAN JOSE (10 intervenciones) el 06/12/2007 14:26:13
EN 1º LUGAR, AGRADECEROS LA AYUDA HASTA AHORA, PRONTO ME TOCARA A MI CON COMPAÑEROS QUE YA ME LA SOLICITAN.
ATASCAO ESTOY.
=SI(A2="M";"J";SI(A2="F";"FJ")) quiero el resultado en la A3.
HASTA AQUI CORRECTO, EN UNA CASILLA COLOCARE FEMENINO (F) O MASCULINO (M) Y CON ESA REFERENCIA NECESITO OBTENER UNA CATEGORIA:
pero la formula anterior no me vale por que me dice que si A2 es M entonces A3 sería J, y sí A2 fuera F, entonces A3 sería FJ.

PERO NECESITO AGREGAR MÁS DATOS, LA EDAD que esta en la casilla A1.
Es decir:
Si A1 fuera igual o menor que 18, y A2 fuera "M" entonces el resultado de A3 sería "J"
Si A1 fuera entre 19 y 39, y A2 fuera "M" entonces el resultado de A3 sería "S"
Si A1 fuera entre 40 y 49, y A2 fuera "M" entonces el resultado de A3 sería "VA"
...
Y CON EL FEMENINO LO MISMO, es decir: pero si
Si A1 fuera igual o menor que 18, y A2 fuera "F" entonces el resultado de A3 sería "FJ"
Si A1 fuera entre 19 y 39, y A2 fuera "F" entonces el resultado de A3 sería "FS"
Si A1 fuera entre 40 y 49, y A2 fuera "F" entonces el resultado de A3 sería "FVA"
....

MASCULINO
CATEGORIAS: JUNIOR (de 1 a 18 años) ............. J
CATEGORIAS: SENIOR (de 19 a 39 años) .......... S
CATEGORIAS: VETERANO A (de 40 a 49 años) ..... VA
CATEGORIAS: VETERANO B (de 49 a 59 años) ...... VB
CATEGORIAS: VETERANO C (de 59 a 99 años) ...... VC

FEMENINO
CATEGORIAS: JUNIOR (de 1 a 18 años) ............. FJ
CATEGORIAS: SENIOR (de 19 a 39 años) .......... FS
CATEGORIAS: VETERANO A (de 40 a 49 años) ..... FVA
CATEGORIAS: VETERANO B (de 49 a 59 años) ...... FVB
CATEGORIAS: VETERANO C (de 59 a 99 años) ...... FVC

ESTA FORMULA PARECE ALGO IMPOSIBLE. ME VOY A VOLVER LOCO.
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder

RE:ATASCAO ESTOY

Publicado por mrproper (127 intervenciones) el 06/12/2007 15:26:42
Yo obtendria en una columna los resultados teniendo en cuenta sólo las edades, es decir, obtendria las J, S, VA, VB, y VC. Con la funcion SI() deberias poder hacerlo facilmente, y ya te digo que solo teniendo en cuenta el tramo de edades, y nada del sexo. Una vez obtengas en la columna los resultados, entonces ya haces alusión al sexo, de forma ke si es "M" repites el resultado de la columna anterior (pues no ha ke añadir nada) y si es "F" añades al principio la letra F con la funcion CONCATENAR().

Espero haberte ayudado. Un saludo,
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:ATASCAO ESTOY

Publicado por jcs (494 intervenciones) el 06/12/2007 23:05:50
Mira a ver si te vale esto:

=SI(A2="M";"";"F")&SI(A1<19;"J";SI(A1<40;"S";SI(A1<50;"VA";SI(A1<60;"VB";"VC"))))

Espero que te funcione.

Un saludo.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:ATASCAO ESTOY

Publicado por JUAN JOSE (10 intervenciones) el 07/12/2007 17:41:57
VAYA MÁQUINA, CASTRILLO.

AL MISTER PROPER ANTERIOR LE ACABAS DE LEVANTAR LA MORAL.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:ATASCAO ESTOY

Publicado por JUAN JOSE (10 intervenciones) el 07/12/2007 17:45:55
perdón, perdón, quería decir al URIBANABREAK,

Mr. proper lo siento, amigo.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:ATASCAO ESTOY

Publicado por mrproper (127 intervenciones) el 07/12/2007 17:50:21
Eso espero tio, porke lo unico ke he intentado es ayudar. Si ha sido asi me alegro y sino lo siento. Lo unico es ke el tio de antes creo ke se ha "descolgao" un poco.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar