Excel - contar en excel con varios criterios

   
Vista:

contar en excel con varios criterios

Publicado por Iván R (2 intervenciones) el 09/01/2008 23:31:39
Hola tengo una consulta , como puedo hacer que una funcion me cuente una serie de valores, pero en otra columna tenga registros repetidos.
En otras palabras, tendo una columna que se llama Codigo y otra Producto X

EJEMPLO:

A B
CODIGO PRODUCTO X
60100034 $ 25
60100184 $ 25
60100193 $ 25
60100206
60100034 $ 25
60100266
60100184 $ 25
60100277 $ 25

Si le pongo la funcion =contar(b2:b9) me da como resultado 5

pero si vemos la columna A hay codigos que se repiten , entonces solo me interesa que me cuente los codigos que no estan repetidos, una funcion que me cuente la columna B tomando en cuenta el criterio del A.
RESULTADO = 2

Gracias de antemano.

Saludos.
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder

RE:contar en excel con varios criterios

Publicado por Richard  (2 intervenciones) el 10/01/2008 14:03:24
Prueba con las tablas dinamicas.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:contar en excel con varios criterios

Publicado por José Luis (700 intervenciones) el 10/01/2008 21:30:21
Crea una fórmula en otra columna que te indique si el número está repetido o no. p.ej. CONTAR.SI(A$2:A$9;A2).
Después con la función SUMAPRODUCTO (mira este link http://www.xldynamic.com/source/xld.SUMPRODUCT.html) podrás realizar el conteo que quieres.

Saludos
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:contar en excel con varios criterios

Publicado por nelson (1 intervención) el 24/11/2008 03:41:15
=SUMAPRODUCTO((D8:D11859<>"")/CONTAR.SI(D8:D11859;D8:D11859&""))
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar