Excel - Funcion SI anidada + de 7 veces

   
Vista:

Funcion SI anidada + de 7 veces

Publicado por ANA (1 intervención) el 03/02/2008 19:01:22
Buenas,

Necesito calcular unos complementos específicos que según su código serán unos euros u otros, osea si es código 1 el complemento es de 100 euros, si es código 2 el complemento es de 225 euros y así sucesivamente hasta un total de 12 complementos distintos, tengo que usar la función SI para esto, pero el problema es que no se pueden anidar más de 7 niveles.
¿Cómo puedo calcular esto?

¿Si no puedo anidar más de 7 funciones SI tengo que calcularlo manualmente?

Si alguien me puede ayudar estaría muy agradecida.

Saludos,
Ana.
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder

RE:Funcion SI anidada + de 7 veces

Publicado por mrproper (127 intervenciones) el 03/02/2008 19:25:33
Pues yo crearía 3 columnas, 2 para cálculos y la 3ª para mostrar el complemento definitivo. Me explico. Como no puedes anidar mas de 7 funciones SI, haría un cálculo en la primera columna por si el código fuera del 1 al 6. La 2ª columna la usaría por si el código fuera del 7 al 12. La 3ª columna sería la suma de las 2 primeras. La segunda columna sólo se calcularía si la primera fuera igual a 0.

Si en la columna A están los códigos, empezando por A2 (en A1 supongo ke está el encabezado), usaríamos las columnas B y C para los cálculos y la D para mostrar el resultado del complemento definitivo que corresponda.

En B2 pondríamos la fórmula:

=SI(A2=1;100;SI(A2=2;225;SI(A2=3;300;SI(A2=4;400;SI(A2=5;500;SI(A2=6;600;0))))))

En C2 la fórmula:

=SI(B2=0;SI(A2=7;700;SI(A2=8;800;SI(A2=9;900;SI(A2=10;1000;SI(A2=11;1100;SI(A2=12;1200;0))))));0)

Y en D2:

=SUMA(B2:C2)

Lógicamente, debes cambiar los complementos por las cantidades que correspondan. Las 2 primeras canatidades (100 y 225) las he puesto según tu pregunta, pero las siguientes me las he inventado (de 100 en 100).

Espero haberte ayudado. Un saludo,
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:Funcion SI anidada + de 7 veces

Publicado por JuanC (792 intervenciones) el 03/02/2008 19:25:35
suponiendo que el código está en A1

A1=0 -> ""
A1=1 -> 100
A1=2 -> 225
A1=3 -> 500

=ELEGIR(((A1=1)*1 + (A1=2)*2 + (A1=3)*3)+ 1; ""; 100; 225; 500)

Saludos desde Baires, JuanC
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:Funcion SI anidada + de 7 veces

Publicado por mrproper (127 intervenciones) el 03/02/2008 19:51:48
Si es ke el JuanC es un máquina. Yo soy más chapucero... Gracias maestro.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:Funcion SI anidada + de 7 veces

Publicado por Cesar (151 intervenciones) el 04/02/2008 21:45:24
mas vale tarde que nunca

Lo mas facil seria usar la funcion BUSCARV, creando una tabla de la siguiente manera

A B C
1 100
2 200
....
12 2000

Entonces hariamos buscarv(a1,tabla,2)

Espero haber ayudado a solucionar el probnlema

Cesar
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:Funcion SI anidada + de 7 veces

Publicado por sandy (1 intervención) el 11/03/2008 23:26:16
es posible utlizar la funcion si y si es verdadero te sume valores
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:Funcion SI anidada + de 7 veces

Publicado por Marvin Osorio (368 intervenciones) el 11/03/2008 23:29:06
Claro que si se puede Sandy, solo debes de indicar que es lo que necesitas exactamente hacer....

Salu2
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:Funcion SI anidada + de 7 veces

Publicado por claudia  (1 intervención) el 08/05/2009 02:05:38
quisiera saber que es un si anidado
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar