Excel - SUMA NOMBRES Y DISCRIMINA APELLIDOS

   
Vista:

SUMA NOMBRES Y DISCRIMINA APELLIDOS

Publicado por JOSHEP (2 intervenciones) el 05/05/2008 18:36:51
NECESITO UNA FORMULILLA PARA SUMAR IMPORTES:
Tengo en la columna A tengo nombres y apellidos
Y en la columna B tengo los importes.

Necesitaba la formula que sumara los importes con relación a los nombres; por ejemplo:

Columna A Columna B
PEDRO DE LA ROSA 100
PEDRO ANTONIO 80
JOSE MANUEL 60
PEDRO RODRIGUEZ 120
JOSE ANTONIO 30

LA Formula tendría que sumar todos los importes de las personas que empezaran por PEDRO ........ y sería 300
Y para los que empezaran por JOSE una nueva formula que me daría como suma 90

ESTO ES POSIBLE ? AH, NO TENGO LA OPCIÓN DE DIVIDIR LA COLUMNA A en dos
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder

RE:SUMA NOMBRES Y DISCRIMINA APELLIDOS

Publicado por Abraham Valencia (2418 intervenciones) el 05/05/2008 18:49:47
=SUMA(SI(IZQUIERDA(C8:C11,HALLAR(" ",C8:C11)-1)="Abraham",D8:D11))

Es matricial, ingresala presionando CTRL+SHIFT+ENTER sino, no funcionara

Abraham
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:SUMA NOMBRES Y DISCRIMINA APELLIDOS

Publicado por Luis Fernando (805 intervenciones) el 05/05/2008 18:51:24
Ok no he dicho nada la de Abraham esta mucho mejor.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:SUMA NOMBRES Y DISCRIMINA APELLIDOS

Publicado por Luis Fernando (805 intervenciones) el 05/05/2008 18:49:52
Puedes generar una columna con los nombres asi:

=EXTRAE(A2;1;ENCONTRAR(" ";A2)-1)

y en otra columna con SUMAR.SI traer el total de cada uno, o en lugar de esto ultimo hacer una tabla dinámica para el resumen de ellos.

Saludos desde Pereira Colombia
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:SUMA NOMBRES Y DISCRIMINA APELLIDOS

Publicado por galileogali (107 intervenciones) el 06/05/2008 05:32:33
supongamos en A1 PEDRO
=SUMAR.SI(C1:C4;A1&" *";D1:D4)

EN C1: C4 , los Nombres y apellidos
en D1:D4, los importes.
nOTESE QUE LA CADENA DEBE SER " *" Y NO "*"

Ahora yo pregunto al consultante: cual es la finalidad de este recurso?
tiene mucho sabor a ejercicio escolar...

GALILEOGALI
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:SUMA NOMBRES Y DISCRIMINA APELLIDOS

Publicado por Luis Fernando (805 intervenciones) el 07/05/2008 01:58:06
Aun siendo ejercicios escolares creo deberian de intentar hacerlo primero por su cuenta y consultar ya en foro para resolver las dudas no el ejercicio completo.

Además de las otras recomendaciones de calidad de los datos y claridad en el planteamiento.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar