Utilizamos cookies propias y de terceros para mejorar la experiencia de navegación, y ofrecer contenidos y publicidad de interés.
Al continuar con la navegación entendemos que se acepta nuestra política de cookies.
Iniciar sesión Cerrar
Correo:
Contraseña:
Entrar
Recordar sesión en este navegador
Crear cuenta

Excel - BuscarV problemas con la matriz

Vista:
Me gusta: Está pregunta es útil y esta clara
0
No me gusta: Está pregunta no esta clara o no es útil
 
Asunto:BuscarV problemas con la matriz
Autor:Mario (2 intervenciones)
Fecha:21/05/2008 19:27:03
Para buscar vertical puedo elelegir un rango de valores, o crear una matriz con un nombre, pero deseo que si tengo dos o mas matrices a evaluar el mismo dato, yo pueda referenciar el nombre de la matriz que desee a una celda.

ej:

=SI(I18="";"";SI(IGUAL(I18;BUSCARV(I18;PR;1));CONCATENAR(BUSCARV(I18;PR;2))))

pero en vez de PR, colocar la referencia a una celda,
A1=PR

=SI(I18="";"";SI(IGUAL(I18;BUSCARV(I18;a1;1));CONCATENAR(BUSCARV(I18;PR;2))))

para yo cambiar automaticamente la matriz a buscar

pero de la manera anterior no funciona, quisiera saber como se hace
Responder Subir
información
Otras secciones de LWP con contenido similar...
Me gusta: Está respuesta es útil y esta clara
0
No me gusta: Está respuesta no esta clara o no es útil
 
Asunto:RE:BuscarV problemas con la matriz
Autor:Luis Fernando (806 intervenciones)
Fecha:22/05/2008 02:18:16
Dentro de la funcion BUSCARV se puede anidar la función INDIRECTO y con ella poder buscar en diferente matriz segun el resultado de una celda,

En este ejemplo

=BUSCARV(C28;INDIRECTO(C30);2;0)

segun lo que tenga en la celda C30 se puede consultar en una matriz u otra, pero es necesario que lo que se tenga en la celda C30 corresponda a rangos o matrices similares.

Cordial saludo desde Pereira Colombia
Comentar Subir
Me gusta: Está respuesta es útil y esta clara
0
No me gusta: Está respuesta no esta clara o no es útil
 
Asunto:RE:BuscarV problemas con la matriz
Autor:Marvin Osorio (368 intervenciones)
Fecha:22/05/2008 15:45:35
Lo que dice Fernando es correcto, un ejemplo de lo que tu quieres es:

tenemos una matriz en A1:B5 y definimos el nombre de Tabla1
tenemos otra matriz en E1:F5 y definimos el nombre de Tabla2

ya con esto pues hacemos la siguiente formula

=BUSCARV(D8,INDIRECTO(B10),2,FALSO)

Suponiendo que en D8 está el dato a buscar, y en B10 tenemos ya se una validación (Datos / Validacion / Configuracióndon / tipo Listade se listen las Tabla1 y Tabla2, o bien se ingresa este dato manualmente

Y así cada ves que cambies el dato en B10 te cambiara la matriz de acuerdo al nombre definido

OJO el nombre definido para cada rango, debe ser igual al nombre que se escribe o selecciona en B10

Salu2
Comentar Subir
Me gusta: Está respuesta es útil y esta clara
0
No me gusta: Está respuesta no esta clara o no es útil
 
Asunto:RE:BuscarV problemas con la matriz
Autor:Mario (2 intervenciones)
Fecha:22/05/2008 17:20:51
Muy bien,,...me funciono muchas gracias a todos
Comentar Subir
Me gusta: Está respuesta es útil y esta clara
0
No me gusta: Está respuesta no esta clara o no es útil
 
Asunto:cambiar formula de matriz
Autor:MAX (1 intervención)
Fecha:18/07/2008 03:10:55
me enciaron una matriz con formulas , como le hago apra cambiar algun dato de las formulas dentro de la matriz para que funcione
es que le quiero cambiar algo a la formula y me quita los corchetes de la matriz
gracias
max fragoso
maxfragoso@hotmail.com
Comentar Subir