Utilizamos cookies propias y de terceros para mejorar la experiencia de navegación, y ofrecer contenidos y publicidad de interés.
Al continuar con la navegación entendemos que se acepta nuestra política de cookies.
Iniciar sesión Cerrar
Correo:
Contraseña:
Entrar
Recordar sesión en este navegador
Iniciar sesiónIniciar sesiónCrear cuentaCrear cuenta

Excel - Sentencia condicional SI

  Imprimir  
Vista:
Me gusta: Está pregunta es útil y esta clara
0
No me gusta: Está pregunta no esta clara o no es útil
 
Asunto:

Sentencia condicional SI

Autor:jose (3 intervenciones)
Fecha:23/05/2008 16:28:26
Saludos

Veo para mi sorpresa el que la sentencia IF o en Excel en español, SI
no deja que la condicion involucre dos o mas con OR o AND

Ejemplo:

IF A1>=2 OR A2<=4 ------> mostrar "HOLA" en la celda
ELSE -------> mostrar "CHAO" en la celda

En espanol supongo seria:
SI A1>=2 O A1<=4 ------> mostrar "HOLA" en la celda
SINO -------> mostrar "CHAO" en la celda

Veo que el SI en Excel es:
SI(A1>=2;"HOLA";"CHAO")

Pero eso no me sirve porque necesito evaluar A1>=2 and/or A1>=4
Veo que en los "SI" condicionales no se puede poner AND, OR.

Como podria hacerse esto?
Gracias a quien pueda proporcionarme el tips para solucionar esto.
saludos
Responder
información
Otras secciones de LWP con contenido similar...
Me gusta: Está respuesta es útil y esta clara
0
No me gusta: Está respuesta no esta clara o no es útil
 
Asunto:

RE:Sentencia condicional SI

Autor:jcs (447 intervenciones)
Fecha:23/05/2008 17:41:01
Muy buenas,

Mira a ver esto:

=SI(O(A1>=2;A2<=4);"HOLA";"CHAO")

Un saludo. Juanjo.
Comentar
Me gusta: Está respuesta es útil y esta clara
0
No me gusta: Está respuesta no esta clara o no es útil
 
Asunto:

RE:Sentencia condicional SI

Autor:jose (3 intervenciones)
Fecha:23/05/2008 18:24:08
Muchas gracias amigo jcs, pero parece que no evalua realmente, o no respeta el rango, ya que siempre muestra "HOLA", si el dato el la celda esta fuera de ese rango, no cambia a CHAO, por lo que al parecer, no esta tomando en cuenta la evaluacion dentro del SI.
Comentar
Me gusta: Está respuesta es útil y esta clara
0
No me gusta: Está respuesta no esta clara o no es útil
 
Asunto:

RE:Sentencia condicional SI

Autor:JAG (139 intervenciones)
Fecha:23/05/2008 18:40:34
Si Funciono...............
Comentar
Me gusta: Está respuesta es útil y esta clara
0
No me gusta: Está respuesta no esta clara o no es útil
 
Asunto:

RE:Sentencia condicional SI

Autor:jose (3 intervenciones)
Fecha:23/05/2008 21:39:30
Perdon, un descuido mio, error de sintaxis, entre punto y comas, si funciona.
Muchas gracias me ha sido de gran ayuda para solventar el problema de la validacion con rango. :)
Comentar
Me gusta: Está respuesta es útil y esta clara
0
No me gusta: Está respuesta no esta clara o no es útil
 
Asunto:

Sentencia condicional SI

Autor:jesus (1 intervención)
Fecha:04/10/2010 05:47:15
necesito que me muestre lo que hay en la celda A1 y A2 de la Hoja 1 y lo pueda ver en la celda B2 y B3 en la hoja 3
Gracias
Comentar
Me gusta: Está respuesta es útil y esta clara
0
No me gusta: Está respuesta no esta clara o no es útil
 
Asunto:

RE:Sentencia condicional SI

Autor:oswaldo (1 intervención)
Fecha:13/11/2009 15:29:44
tutoreal en sentencia si en excel
Comentar