FileMaker - mostrar campo en un portal según relación

   
Vista:

mostrar campo en un portal según relación

Publicado por bpc (21 intervenciones) el 10/01/2008 23:06:43
Hola, realmente estoy atascada en un punto y no se si voy a saber explicarme. A mi me parece mas brujería que programación ¡sos!!!
Tengo una tabla llamada tdatos de la que tengo dos relaciones con lo que queda como tdatos y tdatos2. En una presentación he puesto un portal con un campo y un botón en el portal para que me lleve al registro relacionado.
Cuando pongo el portal de tdatos con el campo de tdatos lo muestra perfectamente, tanto el campo como el botón. Si no hay ningún dato, como el campo está sombreado, se ve el color del campo y se ve que está vacío.
En cambio, cuando pongo el portal de tdatos2 con el campo de tdatos2 no lo muestra, no muestra el campo ni el color de campo ni el botón ....¡pero si que hay algún dato! porque si pulso donde se supone que está el botón, aunque le botón no se ve si que me lleva al campo relacionado. Es como si fuera todo igual pero el portal estuviera por encima y no dejara mostrar el campo y el botón pero ya he probado a enviar al fondo y esas cosas. Además es curioso que cambio la relación de origen y el origen del campo y se ve, cuando en ese caso no cambio nada relacionado con formato y esas cosas.
Agradezco cualquier sugerencia porque ya no se que mas probar.
Muchas gracias!
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder

RE:mostrar campo en un portal según relación

Publicado por Cesar (213 intervenciones) el 15/01/2008 09:16:48
Pero... si solo tienes una tabla, ¡¡no puedes tener un portal!!. Un portal SOLO sirve para "ver" registros de otra tabla.
Si lo que tienes son 2 tablas tdatos y tdatos2 relacionadas, lo mas probable es que sea un tema de "vista". Prueba a enviar el botón al fondo o (si no te pesa mucho), mandarmelo a mi correo
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:mostrar campo en un portal según relación

Publicado por bpc (21 intervenciones) el 15/01/2008 22:45:22
No claro, perdona, por quererlo simplificar y poder explicarme lo he reducido demasiado. En realidad la base tiene como 15 tablas. Es una base para un servicio de cardiología donde tengo el paciente, consulta, ingreso, analítica, eco, electro, ergometría ... y otras muchas pruebas. Con cada prueba relaciono la paciente con el NHC (nº de historia clínica). Para relacionar las pruebas con un ingreso o consulta, además de por paciente lo hago por fecha. Si el paciente ha estado ingresado del 5 al 10 de octubre, las ecos de ese ingreso son las de ese paciente que están hechas entre esas fechas.
Una de las presentaciones es el historial del paciente. Ahí tengo un portal con las últimas analíticas del paciente, otro con las últimas ecos, otras con las últimos electros... todo perfecto . Se relaciona con el nhc del paciente y se ordenan los portales por fecha de mayor a menor
En la presentación del ingreso, tengo un portal con las analíticas del ingreso (relacionado por nhc y fechas), otro portal con las ecos, otro con los electros... De todos estos portales que son como 4 o 5 de momento hay uno, el de los electros, que en esta presentación no me lo muestra. No me lo muestra ni cuando no tiene datos ni cuando si que los tiene que coincida. Y cuando tiene datos, aunque no los muestra, si pincho encima los muestra, es decir que si que tiene los datos cogidos.
Lo curioso es que el resto si que van, no se cual puede ser el motivo. He revisado la relación, lo he enviado al fondo, lo he borrado y vuelto a crear varias veces, copiado formato de los otros, copiado entero de los otros portales y luego cambiado el origen de los datos y del portal, .... en fin, que creo que lo he probado casi todo.
No se si me he explicado lo suficiente. Perdona que no te lo mande, pero tiene datos reales de pacientes. De todas maneras si no puedo mandarte unos pantallazos o algo así.
Gracias de nuevo.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:mostrar campo en un portal según relación

Publicado por Cesar (213 intervenciones) el 16/01/2008 14:16:03
No se me ocurre mas. Salvo que los campos queden fuera del portal y por eso SI que te funcione el ir al registro relaccionado, pero no te funcione el ver el portal.
Lo que te decia era que me mandases un archivo "clon" (por verlo) pero puedes mandarme tambien una captura de pantalla de la presentación del portal y otra en modo presentación
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:mostrar campo en un portal según relación

Publicado por bpc (21 intervenciones) el 04/02/2008 12:24:32
Al final borré la tabla y la volví a crear y parece que funciona. Muchas gracias de todas formas.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar