Flash - Tengo un problema al crear una película

   
Vista:

Tengo un problema al crear una película

Publicado por EMANI (11 intervenciones) el 27/07/2008 09:24:57
Tengo éste código:
on (press) {load_mc = this.createEmptyMovieClip("logo_mc", 0);
load_mc.loadMovie("rodrigobotet.swf","logo_mc");
_root.onEnterFrame = function() {
if (load_mc.getBytesTotal()>1) {
if (load_mc.getBytesTotal() != load_mc.getBytesLoaded()) {
trace("cargando");
} else {
load_mc.gotoAndPlay(2);
delete _root.onEnterFrame;
}
}
};

}

Se carga el movieclip en el swf principal.
El problema que tengo es que los botones del swf principal aunque no se vean siguen estando activos ya que el puntero del mouse cambia de forma.
Me podéis ayudar.
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder
información
Otras secciones de LWP con contenido de Flash
- Cursos de Flash
- Temas de Flash
información
Cursos y Temas de Flash
- Manual de Flash
- Curso de Flash 5
- Manual de Macromedia Flash MX

RE:Tengo un problema al crear una película

Publicado por sabate (1 intervención) el 27/07/2008 19:31:17
Supongo que lo que te pasa es que cuando cargas el movieclip y se superpone al swf principal los botones de éste último siguen estando activos aunque no se vean.
A mí me pasa lo mismo y no te puedo solucionar el asunto. Un saludo
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:Tengo un problema al crear una película

Publicado por emani (11 intervenciones) el 29/07/2008 13:18:56
Una de las soluciones a mano que he pensado es la de poner después de:
load_mc.gotoAndPlay(2);
boton1._visible=false;
boton2._visible=false;
.....
.....
....
Parece que funciona, pero supongo que habrá otra solución con menos trabajo.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

Problema solucionado

Publicado por emani (11 intervenciones) el 29/07/2008 13:26:58
http://www.after-hours.org/blog/archives/2004/07/14/movieclipenabled-versus-invisible_button/
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar