Flash - Problema con Custom Class

   
Vista:

Problema con Custom Class

Publicado por Javier (2 intervenciones) el 23/01/2012 17:58:18
Hola a todos.
Tengo un problema con una custom class realizada para un MovieClip. Básicamente es lo siguiente:

La estructura es:

- (1) Html principal.
|-(2) Pelicula Flash
|- (3) Movie Clip
|- (4) ScrollPane
|- (5) MovieClip
|- MovieClip (6) --> Custom Class (7)

Es decir, un html (1) que carga una película flash (2) en la que hay un Movie Clip (3) con un ScrollPane (4).
En ese ScrollPane (4) se carga otro MovieClip (5) EXTERNO en el cual hay hay un MovieClip (6) -que funciona como botón- linkado a una Custom Class (7).

La cuestión es la siguiente. En la clase (7) una de las cosas que hago en el constructor es ver si hay un RollOver o un RollOut y hacer ciertas cosas dependiendeo de ello en el MovieClip (6) - Al qu está linkada.

Cuando compilo el movieClip (5), en el que se encuentra el MC-botón (6) todo funciona correctamente, pero al ejecutarlo desde el navegador, o incluso desde la película flash inicial (2) no funciona nada. Es más, ni el código stop(); que tiene en el fotograma 1 funciona pues se ejecuta en bucle.

¿Alguien puede decirme qué está pasando?
¿Cómo puedo solucionarlo?

Gracias
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder

Problema con Custom Class

Publicado por JAvier (2 intervenciones) el 23/01/2012 18:00:57
Por cierto, el linkado lo hago con las opciones:

- Export for Action Script
- Export in first frame.

Gracias
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar