FoxPro/Visual FoxPro - soporte de VF 7.0

   
Vista:

soporte de VF 7.0

Publicado por gabriela (25 intervenciones) el 03/11/2008 17:53:43
Hace unos dias llegéo este mail.

"1. Recientemente Microsoft Corp. ha girado una comunicación de nivel global a todos los Development Partners (de los que formamos parte) para informar que ha retirado todo soporte técnico y no garantiza la compatibilidad futura a los productos desarrollados en Visual Fox en versiones anteriores a la 9, y que ésta será la última versión del producto, mantendrá el servicio de soporte y compatibilidad solamente hasta el 01/01/2011. Posteriormente los sistemas deben migrarse a tecnología .NET.

2. Este cambio afecta directamente a la mayoría de nuestros usuarios, ya que ello significa que muchos productos o actualizaciones que se liberen al mercado (de cualquier producto de software y de cualquier fabricante) pueden afectar el correcto funcionamiento de muchos de nuestros sistemas y no podemos precisar si pueden alterar o destruir datos existentes.

3. Este fenómeno ya se registró cuando en el mes de marzo pasado la compañía Grisoft proveedora del antivirus AVG (de uso libre y sin costo, por lo tanto muy difundido), envió un update que destruyó todas las aplicaciones basadas en VisualFox6. Circunstancia que fue corregida en el día por la firma proveedora, pero obligó a nuestros usuarios a tener que reinstalar todos los sistemas. Lamentablemente algunos perdieron irremediablemente su datos debido a la falta de backups y otros tuvieron que reprocesar mucha información no contenida en las copias de seguridad.

Yo tengo una aplicacion desarrollada en vf7, me gustraía saber si esto es verdad y si a pesar de esto no me conviene migrarla a VF 9.0. Que trastornos me podría causar y si hay que hacer muchas modificaciones o simplement es cuestión de abrir el proyecto en VF 9 y listo....
Gracias. Espero respuesta
Gabriela
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder

RE:soporte de VF 7.0

Publicado por TITO (311 intervenciones) el 08/11/2008 04:13:55
Desconozco si existira una destruccion de futura de aplicaciones basadas en VFP o algo similar. Pero lo cierto es que VFP en todas sus versiones se descontinuó, eso es un hecho, y lo del soporte a VFP9 es tambien es verdad. Pero no por eso los sistemas van a dejar de funcionar, todavia tenemos tiempo para ir estudiando nuevas tecnologias.
Respondiendo a una parte de tu pregunta:
Yo tenia aplicaciones en VFP6, instalé VFP9 (sin desintalar el VFP6) y no me dio ningun problema, el proyecto se compilo perfectamente y ambas versiones coexisten sin ninguna interferencia, por lo cual comence a usar VFP9 para aprovechar muchas ventajas que tiene en relacion a las versiones anteriores.
Plinio del foro me respondio que hay varias herramientas o librerias que posibilitan que tu aplicacion VFP9 corra sobre la WEB. Buscala y me comentas si la has estudiado y que tal te fue.
TITO
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar