FoxPro/Visual FoxPro - No hay ninguna tabla abierta en el area de trabajo

   
Vista:

No hay ninguna tabla abierta en el area de trabajo

Publicado por juan Ayala (76 intervenciones) el 26/12/2008 13:14:41
Genero un report, al visualizar voy de pagina en pagina y me sale este error, no se porque, pero pierde el enfoque del cursor generado

"No hay ninguna tabla abierta en el area de trabajo actual"

Alguien puede darme una mano, porque ya estoy desempleado por causa de no solucionar este error, y nadie me pudo decir como resolverlo

Saludos cordiales

Juan Ayala
Auncion-Paraguay
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder

RE:No hay ninguna tabla abierta en el area de trab

Publicado por sergio (697 intervenciones) el 26/12/2008 13:19:50
Hola
Haces referencia desde el reporte a alguna funcion que pueda hacer que pierdas el cursor al cual tenes que hacer referencia?
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:No hay ninguna tabla abierta en el area de trab

Publicado por juan Ayala (76 intervenciones) el 26/12/2008 13:55:07
bueno, realmente cambie todos los nombres de mi cursor por su se tratara de eso, le asigne v_nombre,v_codigo etc, cuando le envio al report despues de generar el cursor o me dice "No hay ninguna tabla abierta...." o no reconoce mis campos del cursor generado... me esta volviendo loco
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:No hay ninguna tabla abierta en el area de trab

Publicado por sergio (697 intervenciones) el 26/12/2008 14:12:56
Hace una cosa
debaguealo y frena el programa con un set step on antes de imprmir el reporte
Hace un set desde la ventana de comando y verifica que tengas todos los cursores abiertos, y verifica que el nombre de los cursores que tulizas estn bien escritos en el reporte
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:No hay ninguna tabla abierta en el area de trab

Publicado por juan (76 intervenciones) el 05/01/2009 22:23:48
Hola, en verdad lo que sucedia es que daba problema de memoria, como dentro de un formulario tenia un grid con la tabla del cual enviaba a a un cursor, para luego imprimirlo, en verdad dividi las funciones y el reporte lo tuve que enviar a otro formulario independeinte , la verdad que la primera forma era mas practica para el operador, pero en fin tube que separara los procesos, hasta ahora no me da el terrible error C0000005!!!, gracias por sus consejos, lo tube muy en cuenta, lo intente pero al final tube que hacerlo asi. GRACIAS !!!
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar