FoxPro/Visual FoxPro - Error usando Buffering

   
Vista:

Error usando Buffering

Publicado por CarlosA (86 intervenciones) el 29/04/2009 14:26:59
Hola.. tengo un formulario en el que estoy abriendo en el Entorno de Datos tres tablas de una base de datos, la idea es que en el formulario trabajo las tablas, les tengo BufferModeOverride = 5
pero al momento de insertar datos en la tabla Visual Foxpro genera un error de programa y se sale, presenta el tipico error de "Este programa ha efectuado una operacion no valida... bla bla...

porque puede ser esto.. ya intente de varias maneras insertar los datos pero siempre me genera el error...

si alguien sabe que puede ser lo agradezco...
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder

RE:Error usando Buffering

Publicado por Mario (199 intervenciones) el 29/04/2009 17:09:00
Primeramente deberás intentar "aislar" el error, es decir, saber exactamente dónde se produce, es en el momento del append? o cuando se hace el tableupdate?
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:Error usando Buffering

Publicado por CarlosA (86 intervenciones) el 29/04/2009 21:04:00
El problema era en el append, era pq lo resolvi abriendo la tabla directamente y activando el buffering mediante la funcion CURSORSETPROP("Buffering", 5, "nombretabla")

Inicialmente adicionaba el registro con un INSERT de sql pero viendo la ayuda cuando se usa bufferins se debe trabajar con append... cambie esto pero no se resolvio el problema.. asi que decidi hacer lo anterior y ya no me arroja error...

gracias
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:Error usando Buffering

Publicado por Mario (199 intervenciones) el 29/04/2009 22:29:24
Estuve haciendo una prueba sencilla colocando una tabla en el Dataenvironment en modo buffer (5).
Agregué datos con Insert into y anduvo perfecto.
Quisiera saber dónde dice en la ayuda que no se puede usar insert (sql) porque no lo encuentro.
Qué versión de VFP usas?
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar