FoxPro/Visual FoxPro - Grid - no Responde (Muestro Codigo)

   
Vista:

Grid - no Responde (Muestro Codigo)

Publicado por Roberto (17 intervenciones) el 18/07/2009 01:35:09
Hola amigos

...ORDER BY GLBD01CP.NRO_MDR INTO CURSOR TMMD READWRITE

creo un cursor cada ves que doy click a un boton Y MUESTRO LOS DATOS EN UN GRID, LA PRIMERA VEZ LO HACE BIEN PERO CUANDO LO REALIZO POR SEGUNDA VEZ ME SALE QUE MIEMBRO DESCONOCIDO COLUMN1, Y ASI CON TODAS LAS COLUMNAS
POR FDAVOR ALGUIEN QUE PUDIERA AYUDARME 1000 GRACIAS

*
SELECT TMMD
GO TOP
*
WITH Thisform.Grid1
.RecordSourceType = 1
.RecordSource = ''
.Column1.ControlSource = ''
.Column2.ControlSource = ''
.Column3.ControlSource = ''
.Column4.ControlSource = ''
.Column5.ControlSource = ''
.Column6.ControlSource = ''
EndWith
*
WITH Thisform.Grid1
.RecordSourceType = 1
.RecordSource = 'TMMD'
.Column1.ControlSource = 'TMMD.RAZ_CLI'
.Column2.ControlSource = 'TMMD.NRO_MDR'
.Column3.ControlSource = 'TMMD.FEC_INI'
.Column4.ControlSource = 'TMMD.DIASCSM'
.Column5.ControlSource = 'TMMD.CONSUMO'
.Column6.ControlSource = 'TMMD.VALORCONS'
EndWith
*
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder

RE:Grid - no Responde (Muestro Codigo)

Publicado por Pablo (Argentina) (433 intervenciones) el 18/07/2009 15:13:12
Hola Amigo, cosa rara la suya, pero a simple vista y no se si influye en algo o no al grid pero vos pones:

.recordsource = "

cuando deberias poner .recordsource = "" (doble comilla)

no se si tenes ese error en el programa o lo tipeastes mal aca, por ahi si lo tenes mal en tu form, tal vez ese sea el problema.

Suerte!!!!!

Pablo - Argentina
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar