FoxPro/Visual FoxPro - Problemas con los txtbtns

   
Vista:

Problemas con los txtbtns

Publicado por Elsa (36 intervenciones) el 12/08/2009 23:16:58
Cuando corro el ejecutable, al buscar un registro, se abre atras una pantalla blanca,
como puedo hacer para que no se abra esa pantalla ?. Si ejecuto el formulario dentro del visual foxpro esa ventana no aparece. Se comporta de distinta manera.
Y otro problema mas grave, despues de buscar un registro, aveces me quedan deshabilitados los otros botones, que puede esta pasando ?.
Muchas gracias, estoy muy preocupada, no se que pudo haber pasado, porque antes no se deshabilitaban.
Gracias.
Elsa
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder

RE:Problemas con los txtbtns

Publicado por juan286 (179 intervenciones) el 13/08/2009 08:35:35
La pantalla blanca debes espedificarla y por los botones solo se me ocurre es k tienes por ahi un codigo k esta asiendo esto tambien ocurre cuando una tabla se abre mal y el formulario kda colgado
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

JUAN

Publicado por Elsa (36 intervenciones) el 13/08/2009 17:59:37
En el formulario cuando uso el boton buscar, aparece una pantalla blanca sobre el formulario que dice: en el menu :archivo edicion ventana ayuda y sobre esa ventana el cuadro de dialogo para poder buscar.

Cuando busco , depende de los campos, no se deshabilitan los primeros botones, y cuando busco otros campos , si en buscar , elijo "buscar" ,
se deshabilitan los primeros botones y si elijo "todo", no se deshabilitan los botones.
Que extraño !!!. Puede ser que tenga algun error en el formulario ?, por ejemplo
mal algun nombre del campo de la base ?.
Gracias
Elsa
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:JUAN

Publicado por Juan286 (179 intervenciones) el 14/08/2009 13:59:48
Esa ventana es la k aparece una ves se compila tod el sistema es normal si no quieres k aparesce cambia la propiedad ShowWindos a la opcion 2 cmo formulario de niverl superior una ves echo esto en el init del formulario es _screen.visible = .F.

En es caso de los botones el problema radica en la activacion y desactivacion de ls mismo checa cmo estan la propiedad en cada uno de ellos puede k tengas una propiedad de donde no debe ir
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar