FoxPro/Visual FoxPro - Problema para eliminar un registro de una tabla

   
Vista:

Problema para eliminar un registro de una tabla

Publicado por Aprendizxxxx (30 intervenciones) el 02/02/2010 08:35:37
Hola amigos.. tengo un problema cuando quiero eliminar un registro de una tabla, esto a veces sucede a veces no.. cuando quiero eliminar un registro desde un form en ejecucion utilizo el siguiente codigo.

Delete
pack

Teniendo en cuenta que en el entorno de datos en la propiedad exclusive de la tabla la tengo como T.

y siempre me da un mensaje de error que la tabla debe de abrirse en mdo exclusivo

en modo de diseño entro al entorno de datos y browse en la tabla y quiero hacerlo manualmente y siempre me da el mismo error.

ESpero su ayuda..

Gracias.....
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder

RE:Problema para eliminar un registro de una tabla

Publicado por pipo (9 intervenciones) el 02/02/2010 15:21:27
Debe ser sin el pack.
Eso te provoca el problema.
Suerte
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:Problema para eliminar un registro de una tabla

Publicado por aprendiz (30 intervenciones) el 03/02/2010 04:23:16
Bueno pero lo que pasa que si no utilizo el pack, el registro solo queda marcado como eliminado.. lo que se tomaria en cuenta solo seria el Delete.. que sirve para marcar un registro como elinado.. pero yo necesito eliminar completamente ese registro de la tabla y si necesito el pack..

A menos que me ayuden con otra solucion....

No recuerdo muy bien.. pero le escuche a alguien que creo que en el form load... deberia de poner

SET EXCLUSIVE ON o

óóóó OFF,, NO recuerdo muy bien...

Agradeceria...sus ayudas..
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar