FoxPro/Visual FoxPro - No Funcionan a veces las VCX

   
Vista:

No Funcionan a veces las VCX

Publicado por Pablo (Argentina) (433 intervenciones) el 05/07/2010 23:27:45
Hola Amigos del foro, les cuento mi problema a ver que puede ser.
Resulta ser que baja clases (VCX) del sitio de portalfox o de algun otro y resulta que cuando las quiero utilizar en mi aplicacion no funcionar o funcionar a medias o se ven mal los graficos, etc, no da ningun error pero como que no las carga bien o no se como explicarles.
Me pasa ejemplo con la clase Calendrio, si la bajo y la descomprimo y la ejecuto en donde la descargue ahi funciona todo excelente, se ven bien los colores, las flechas, etc, ahora bien yo a esa clase la descomprimo completa en donde tengo mi aplicacion y la agrego a mi proyecto y no me muestra el color de fondo o no me pone la flecha que indica para "siguiente" en su lugar me pone como si estuviera el control ole sin la imagen, y me fije y estan los los jpg, vcx, etc, etc, ¿que puede pasar?.

tambien me ha pasado y con eso alguna que otra vez la hice andar, fue compilando de nuevo la aplicacion en mi maquina y despues llevarla a mi proyecto y ahi salio andando pero no es como deberia, lo mismo tambien me ha pasado con una clase para hacer mas lindos los command button con colores en degradee, no me los carga como deberia.

¿que podra ser? o que tengo que configurar en mi VFP con SP1 para que funcione.

Muchas Gracias

Pablo - argentina
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder

RE:No Funcionan a veces las VCX

Publicado por Charles Benzon (353 intervenciones) el 06/07/2010 06:59:29
Buenas,

En muchas de las clases, los graficos vienen en carpetas y es bueno (para no complicarse) manejar de la misma manera que los ejemplos que las acompañan) en todo caso se puede editar y cambiar la ruta de acceso de las imagenes.
También resulta que los ejemplos solo hacen mención a esa clase y no hay problema porque está incluida en el proyecto, en muchos casos y donde tu aplicación tiene varias clases no es suficiente incluir la clase en tu proyecto, sino tambien tener un comando como:
set classlib <minuevaclase> additive
asi se adicionan a las demás clases.

Espero que te sirva,
un saludo,
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:No Funcionan a veces las VCX

Publicado por es_binario (757 intervenciones) el 06/07/2010 23:49:51
si estas usando foxpro version 9.0 si va a ser por un servipack, de hecho el servipack 2 de vfp 9 corrige problemas visuales en muchos controles, ahora tambien si usas una version anterior, a foxpro anterior a la version 9.0 considera que muchas clases estan pensadas para las caracterisitcas del vfp 9 y no uno anterior, incluso algunas te piden que tengas vfp 9 sp 2 ademas de eso podria ser, que el backcolor no lo tengas en blanco el del screen pero aun asi se deberian de ver, por otro lado no veo que puedas tener, nada mal

podria ser el sedna si es que lo tienes instalado comenta, mas de tu version de foxpro que tienes usando.

Saludos, desde Mexico.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:No Funcionan a veces las VCX

Publicado por pablo (Argentina) (433 intervenciones) el 07/07/2010 20:12:30
Hola Amigo de Mex, mira estoy utilizando el VFP 9.0 con el SP1 español, no lo puedo actualizar al SP2, porque como el VFP 9 no es original, sino que lo baje de la web, se ve que no lo descargo todo o no se que puede estar pasando porque con el SP1 no tuve problemas para actualizar pero con el SP2 me pide un programa o dll no recuerdo ahora que no la encuentra entonces no puede seguir con la instalacion.

si me podes decir de donde descargar bien el VFP 9 con el SP1 a español y el Sp2 y asi lo tengo todo correctamente.
El sedna nunca lo instale ni lo baje, es mas no se ni para que sirve, por ahora con el VFP 9 SP1 me arreglo, pero siempre es bueno estar acualizado, mas cuando ya estoy usando clases como foxcharts y foxypreviwer y otras mas

pero en fin, a tu pregunat de mi version es esa VFP 9 con SP1

Espero tus comentarios y ayuda con bajar el VFP correcto.

Muchas Gracias

Pablo - Argentina

PD: Pudistes solucionaro empezar a ver tu tema de la factura electronica? y el tema del XML te sirvieron los links.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:No Funcionan a veces las VCX

Publicado por es_binario (757 intervenciones) el 09/07/2010 15:09:08
No importa que el foxpro no sea el original, yo he instalado el parche en sistemas de clientes que tienen el foxpro pirata y no pide ninguna validacion, por lo que lo puedes bajar de la pagina de microsoft sin ningun problema.

Con lo que respecta a las facturas electronicas, afortunadamente ya tengo todo, solo me faltaba un poco la operacion con openssl, pero ahorita por cuestiones de trabajo no he podido dedicarme de lleno a la facturas electronicas, mas bien ahorita como te comente por ahi, estroy trabajando con el programa de cambaceo, para intentar, hacer un plano de laz zonas malas, con respecto a los clientes que mas se atrazan o no pagan, en un mapa virtual basandome en cordenadas con el flowchats, por aqui estamos en contacto, bajate el sp2 e instalatelo, resuelve muchos problemas sobretodo si trabajas con windows vista o el windows 7.

Saludos.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar