FoxPro/Visual FoxPro - Reporte

   
Vista:

Reporte

Publicado por victor perez (278 intervenciones) el 21/10/2010 02:22:03
Hola Amigos,

Agregue a mi sistema un ToolBar con botones y una barra de estado inferior. Todo quedó muy bien.

Ahora el problema que tengo es q cuando imprimo un reporte cualquiera, demora un pequeño tiempo y me muestra el Esquema del Reporte (como si estuviera editandolo en VFP).

Ademas de esto agregué un Proceso por el cual se transforma la expresion N (numerica) a Letras.

Extraño lo que sucede pero cierto.

Ademas, hice 3 pruebas...dos en mis computadoras de la casa y otra en la de la oficina ,via remota.

Cuando estoy en la casa, computadora local, pongo el Set Procedure to XXX.prg Additive en el Programa principal (mysis.prg). Luego llamo la funcion desde el comando imprimir y paso los parametros desde el form de facturacion o de caja. Toma el valor del TotalPagado y ejecuta la funcion...

Si corro el programa accediendo a mi computadora remota via escritorio directo (como si estuviera sentado frente al computador remoto) , me manda un error pues dice que no encuentra la funcion.

Para solucionar todo, tuve que incluir el Set procedure to XXX.prg en el evento Click de imprimir.

Extraño es que en dos computadoras funcione bien...y en la otra no y tengo los mismos PRGS, Screens, etc en ambos equipos.

Cualquier comentario, bienvenido.

Victor,
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder