FoxPro/Visual FoxPro - Reporte Lento y no encuentro el error.

   
Vista:

Reporte Lento y no encuentro el error.

Publicado por victor perez (137 intervenciones) el 14/02/2013 02:57:18
Hola amigos,

Tengo un reporte tan sencillo, que toma las variables de memoria de un formulario y lo manda a la impresora.

No tiene nada de especial, pero al momento de imprimir un solo registro...demora un monton para darme el preview.

Tengo el comando . REPO FORM PATIEnt NOEJE TO PRIN PROMPT preview in Screen

Toda la ayuda es bienvenida.


Victor,
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder
Imágen de perfil de Mauricio

Reporte Lento y no encuentro el error.

Publicado por Mauricio (1368 intervenciones) el 14/02/2013 03:27:32
Prueba de esta manera:
REPO FORM PATIEnt TO PRINT preview
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

Reporte Lento y no encuentro el error.

Publicado por victor perez (137 intervenciones) el 14/02/2013 16:16:41
GRacias ...Probaré.


Tengo otra inquietud. Tomo la informacion de una busqueda. La guardo en un cursor y luego lo despliego en un listbox. Usando bases de VFP no tengo ningun problema pero con las bases de Mysql, la informacion se despliega incompleta en las columnas. Es decir, no puedo ver toda la informacion en los campos numericos (double 10,2) que expresan moneda. Por ejemplo, si es 14.00, solo logro ver 14.0 porque el otro cero queda incluido en las lineas verticales. Pero si veo perfectamente los otros campos que son char.

Alguna sugerencia,

Saludos
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar
Imágen de perfil de Mauricio

Reporte Lento y no encuentro el error.

Publicado por Mauricio (1368 intervenciones) el 14/02/2013 16:25:53
Amigo Victor, te podria sugerir que si los datos del cursor son solo para visualizar, porque mejor no transformas los datos numericos a tipo CHAR?
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

Reporte Lento y no encuentro el error.

Publicado por es_binario (757 intervenciones) el 14/02/2013 20:57:31
la lentitud de tu form podria deberse tambien a que tengas una imagen con demasiada resolucion, yo te recomiendo usar imagenes png con una resolucion de unos 200 puntos maximo...

tambien puede deberse a toda la informacion que tenga tus tablas.

encuanto a mysql, no deberias de guardarlo en un listbox, te recomiendo usar un grid... es mejor.

saludos
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

Reporte Lento y no encuentro el error.

Publicado por VICTOR PEREZ (137 intervenciones) el 14/02/2013 23:48:23
HOla A ambos,

Bueno, cambiarlo a Char de pronto puede solucionar el problema ...no lo he intentado...No se si pueda hacer que el cursor sea READWRITE una vez que lo extraigo con sentencia SQL.

Con respecto a imagenes, el reporte no tiene ninguna imagen...no se si es a eso a que te refieres es_binario

Usar un grid, tendria que reprogramar todo ese aspecto, q aunque no es tan importante, no me agrada que me liste los numeros cortados.

Saludos.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

Reporte Lento y no encuentro el error.

Publicado por victor perez (137 intervenciones) el 15/02/2013 04:13:33
Hola Es_Binario: efectivamente use un grid para desplegar los datos del cursor...y efectivamente quedo como queria, los numeros aparecen completos...y como era solo para ver la informacion sin poder manipularla, puse las propiedades adecuadas al GRID para que no se permita editar.

Saludos,
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar