FoxPro/Visual FoxPro - error con propiedad

   
Vista:

error con propiedad

Publicado por Gabriela (25 intervenciones) el 13/03/2014 19:25:48
Hola a todos...estoy tratando de cambiar de VFP7 a VFP9. Le agrgue las instrucciones para no tener problema con los select y los reportes, si bien se que pierdo las ventajas que tiene este ultimo como reporteador. Ya lo hare de a poco.
Peo el problema que tengo es que tengo una clase que es mi foemulario base y ahi por codigo defino el tamaño de la letra, fuente, color de la fuente de los objetos y fondo, etc. Lo tengo en el init, pero me da error que dice que no existe la propiedad. Ej FONTNAME, FORECOLOR, selectedbackcolor. Pongo este codigo en cada formulario en el init y lo mismo me da error. Que puede ser? Por que veo en la ayuda que se utiliza igual estas propiedades.
Este es un ejemplo de como lo pongo
thisform.setall('selectedbackcolor',rgb(215,215,215),'spinner')
thisform.setall('selectedforecolor',rgb(0,0,0),'spinner')
thisform.setall('FontName','ARIAL','textbox')
thisform.setall('FontName','ARIAL','combobox')
Agradezco ayuda, si no voy a tener que definir formulario, por formulario y es un proyecto muy grande!!!!!

Gracias
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder

error con propiedad

Publicado por Saul (676 intervenciones) el 14/03/2014 06:37:17
Me imagino que tines un formulario

que contiene todos estos objetos??

Deberias de probar con los Texbox primero
luego con los label

Etc.

a ver como te funciona con cada uno.

No debiea porque darte problema yo lo probe y no da problema, o bien mandame una de tus pantallas y te la pruebo.

a mi correo

saul.sde@gmail.com

Saúl Hernández
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar