FoxPro/Visual FoxPro - No despliega la ñ ni letras con tilde mi listbox

   
Vista:

No despliega la ñ ni letras con tilde mi listbox

Publicado por Nelson (8 intervenciones) el 03/07/2015 17:37:22
Hola a todos, tengo un listbox para seleccionar un item de mi base de datos, y lo ordena bien, y despliega bien. Pero los nombres de los clientes que tienen "ñ" y letras con tilde los muestra con caracteres diferentes, quisera arreglar esto. Muchas gracias.
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder
Imágen de perfil de Mauricio Antonio

No despliega la ñ ni letras con tilde mi listbox

Publicado por Mauricio Antonio (1368 intervenciones) el 03/07/2015 18:08:00
Actualiza tu codigo de pagina para esa tabla.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

No despliega la ñ ni letras con tilde mi listbox

Publicado por Nelson (8 intervenciones) el 03/07/2015 19:58:47
Te pido disculpas por mi falta de conocimiento, pero podrías detallarme un poco mas que debo de hacer, no entiendo como actualizo la página para esa tabla, gracias.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar
Imágen de perfil de Mauricio Antonio

No despliega la ñ ni letras con tilde mi listbox

Publicado por Mauricio Antonio (1368 intervenciones) el 04/07/2015 00:40:27
Pero puedes leer la ayuda?
revisa este comando: CHRTRANC(cBuscada, cBuscar, cReemplazo)
tambien podrias buscar CODEPAGE.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar
Imágen de perfil de Mauricio Antonio

No despliega la ñ ni letras con tilde mi listbox

Publicado por Mauricio Antonio (1368 intervenciones) el 04/07/2015 01:37:06
prueba con esto que ya funciono antes
Prueba con esto: OEMTOANSI o en su lugar ocupa
GETCP([nPáginaCódigos] [, cTexto] [, cTítuloDiálogo])
Creo que el codigo de pagina que buscas es 1250
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

No despliega la ñ ni letras con tilde mi listbox

Publicado por Nelson (8 intervenciones) el 09/07/2015 16:54:18
Muchas gracias Mauricio, el CODE PAGE que buscaba era el 850, con tu ayuda y la busqueda solucione el problema. Saludos...
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar