FoxPro/Visual FoxPro - Imagenes en formulario no se visualizan en la red

   
Vista:

Imagenes en formulario no se visualizan en la red

Publicado por Josue (18 intervenciones) el 22/03/2016 16:12:00
Amigos una ayuda con esto:
Hice un formulario productos,que incluye una imagen del producto. Todo funciona bien en el pc local. Pero al acceder por la red sale la imagen.

este es el código para poner la imagen, a ver si me pueden ayudar.

1
2
3
4
5
6
7
8
9
10
m.foto = GETFILE("Todos las imágenes soportadas:JPG,BMP,GIF", "Imagen: ","Abrir",0,"Busque la foto")
if empty(m.foto)=.t.
	Wait window nowait'Nada seleccionado'
	return 0
endif
SELECT productos
replace imagen WITH m.foto
 
thisform.iMAge2.Picture = productos.imagen
thisform.Refresh

Asimismo algunas imágenes salen media distorsionadas como pixeleadas en los contornos ¿a que se debera?
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder

Imagenes en formulario no se visualizan en la red

Publicado por Fidel José (319 intervenciones) el 22/03/2016 23:57:15
Habría que ver si la ruta de red no contiene espacios intermedios \\server\mi ruta de datos\imagen.bmp
También es recomendable
thisform.iMAge2.Picture = trim(productos.imagen)

En cuanto al pixelado, repasa las posibilidades de la propiedad Stretch del control image.
También prueba con Themes = .F.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

Imagenes en formulario no se visualizan en la red

Publicado por Josue (18 intervenciones) el 23/03/2016 00:07:05
Muchas gracias estimado, ya solucione el problema con fullpath()
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar