FoxPro/Visual FoxPro - problema con indices en visual fox 6.0

   
Vista:

problema con indices en visual fox 6.0

Publicado por Martin (6 intervenciones) el 12/10/2007 14:06:42
Hola: Tengo el siguiente problema en una aplicacion visual fox 6.0, utilizo indices para acceder mas rapido a las registros, la tabla tiene unos 300.000 registros, pero ultimamente los indices se rompen con mucha facilidad, sin motivo aparente (corte de luz, cuelgue de windows, etc) , el programa captura el error y repara automaticamente los indices y todo sigue normalmente, pero hay veces que no arroja ningun error, abre la tabla con el incide y todo sigue "igual" , hasta que el usuario busca un dato y "no lo encuentra" porque la busqueda esta hecha utilizando el indice y éste no esta entero o no se que, el caso es que la busqueda no lo encuentra, si regenero el indice manualmente todo vuelve a la normalidad, pero lo tengo que hacer yo despues que el uduario me llama, en esos casos el sistema no captura el error, porque todo funciona, es como que le faltaria una parte al indice.
Espero alguna ayuda al respecto, o comentario, todo ayuda.
desde ya muchas gracias.
saludos.
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder

RE:problema con indices en visual fox 6.0

Publicado por Plinio (7771 intervenciones) el 12/10/2007 14:36:35
Es casi seguro que algo está provocando la corupción del indice. Una pregunta, que SP usas?, porque a veces aparecen algunos bugs extraños y es recomendable tener el ultimo indice de esa version.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:problema con indices en visual fox 6.0

Publicado por martin (6 intervenciones) el 12/10/2007 15:31:01
SP (serviPack?) ninguno, vfp 6.0 tal cual se instala del Visual Studio, estaba pensando migrar a vfp 7.0 .. alguna novedad sobre las ventajas de la version 7.0 ??
gracias desde ya.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:problema con indices en visual fox 6.0

Publicado por Ernesto Hernandez (4632 intervenciones) el 12/10/2007 19:22:40
si piensas en migrar te recomiendo que migres a la 9.0

acerca del problema baja el ultimo service pack de la version 6.0

http://msdn2.microsoft.com/en-us/vstudio/aa718363.aspx

Suerte
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:problema con indices en visual fox 6.0

Publicado por Plinio (7771 intervenciones) el 13/10/2007 01:32:45
- Si no tienes ningun service pack de la 6 instalado, de seguro tendras unos extraños problemas que presentan los reportes con las impresoras HPs, si no los has tenido, te verás a una buena broma

Cabiar a una versión mas reciente es buena (yo cambiaria a la 9). Desde la 7 en adelante se introdujeron algunas cosas que vale la pena el cambio, ejemplo:

- Intellisence (esto lo vale todo)
- Reportes mejores
- Imagenes en menues
- Procedimientos almacenados en las bases de datos
- Temas de xp y ciento de cosas mas.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:problema con indices en visual fox 6.0

Publicado por martin (6 intervenciones) el 16/10/2007 13:14:31
gracia a todos desde ya, como dice Plinio si he tenido problemas con los reportes, no recuerdo si la impresora era una HP, pero si los he tenido y MUY extraños.
Primero voy a probar de instalar el SP 5 y si luego no se mejora el tema voy a migrar a la 9.0
muchas gracias a todos
saludos
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:problema con indices en visual fox 6.0

Publicado por Ernesto Hernandez (4632 intervenciones) el 16/10/2007 18:49:52
voy a migrar a la 9.0

lo mas recomendable compañero
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar