FoxPro/Visual FoxPro - Problema para imprimir

   
Vista:

Problema para imprimir

Publicado por Cecy (2 intervenciones) el 17/12/2007 20:10:56
Hola !!
Ojalá me pudieran ayudar con el siguiente detalle:
Tengo una aplicacion que genera un reporte, dicho reporte lo envio a pantalla y el usuario tiene la opcion de imprimirlo o no. Pero al seleccionar que si desea imprimirlo y enviarlo a una impresora local conectada por USB NO IMPRIME NADA , es una hp laserjet 1022; lo que no entiendo es que si selecciona el mismo modelo pero de alguna que se encuentre en red lo realiza perfectamente....
Osea tengo el problema de que local por USB no lo realiza, pero al principio cuando libere la opcion si lo hacia, pero repentinamente ya no trabajo .....
Tambien es importante que sepan que utilizo el comando:

" set printer to name getprinter()" para que el usario elija de un conjunto de impresora la que desea usar.

Agradezco de antemano sus comentarios que tan amablemente me hagan llegar.
Saludos.
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder

RE:Problema para imprimir

Publicado por HELDER B. MARTINEZ (710 intervenciones) el 17/12/2007 20:39:43
HOLA COMO ESTAS? AMIGO USA ESTE CODIGO, YO LO USO PARA ELEJIR LA IMPRESORA QUE YO DESEE Y CONTROLAR EL NUMERO DE COPIAS

report form RUTA Y NOMBRE DE TU REPORTE Noconsole to print prompt Preview

ESPERO TE SIRVE
SALUDES

HELDER MARTINEZ
HONDURAS C.A
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:Problema para imprimir

Publicado por JorgeE (422 intervenciones) el 18/12/2007 22:54:17
Hola cecy, una de las cosas que checa primero es si la impresora esta activa en windows... o esta pausada, en las propiedades de la impresora en windows.
VFP se basa en las configuraciones que tiene windows para impresora, ssiendo indistinto si es usb o paralelo.
otra cosa que puedes checar es si la impresora fue cambiada de puerto USB, es decir : estaba instalada en el USB1 y luego la desconectaron y al conectarla de nuevo quedo en USB2..... checalo.... antes de pensar en algun problema de VFP
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar