FoxPro/Visual FoxPro - problema con editbox

   
Vista:

problema con editbox

Publicado por ovelit (126 intervenciones) el 27/03/2008 21:15:01
saludos foxeros tengo un problemita y es el siguiente

tengo un editbos en una pageframe y esta dentro de la pagina 2

y tengo en el init del form
lo siguiente

thisform.pageframe1.page2.edit1.Value=" "

esto lo hago para limpiar el editbos pero me da un error y es el siguiente

ERROR WITH EDIT1 - VALUE : DATA TYPE MISMATCH

me dice que el dato no es del mismo tipo

poco se limpia lo editbox o q estare haciendo mal
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder

RE:problema con editbox

Publicado por Plinio (7771 intervenciones) el 27/03/2008 21:18:49
Verifica si tu campo de Edicion realmente se llama EDIT1
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:problema con editbox

Publicado por ovelit (126 intervenciones) el 27/03/2008 21:46:15
si plinio se llama edit1
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:problema con editbox

Publicado por Plinio (7771 intervenciones) el 27/03/2008 22:01:46
Entonces verifica si ese Edit tiene algo en el controlsource, si tiene un campo verifica el tipo de dato de ese campo en la tabla. debe de ser memo o character.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:problema con editbox

Publicado por kong (681 intervenciones) el 28/03/2008 05:06:56
Amigo, tambien puedes ver si el edit1.value esta predeterminado como "0" o no esta asignado algun valor que no sea caracter. O por alguna parte del codigo determinaste que edit1.value sea numerico.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar