FoxPro/Visual FoxPro - NO VEO LAS Ñ,ñ Y ACENTOS

   
Vista:

NO VEO LAS Ñ,ñ Y ACENTOS

Publicado por MONICA (51 intervenciones) el 31/03/2008 14:52:41
Tengo el siguiente problema en Visual Fox 6.0 , no veo en los formularios las ñ,Ñ y los acentos, muestra cualquier cosa en su reemplazo, que debo cambiar de la configuracion que no me doy cuenta?
Muchas Gracias
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder

RE:NO VEO LAS Ñ,ñ Y ACENTOS

Publicado por enrique (1041 intervenciones) el 31/03/2008 17:33:32
Creo que tu problema es la configuracion regional y de idioma de Windows
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:NO VEO LAS Ñ,ñ Y ACENTOS

Publicado por CarlosA (86 intervenciones) el 31/03/2008 18:00:41
Solo te sucede con el Visual FoxPro ?? o te sucede con los demas programas.... mira como dice enrique tu configuracion regional...

y tambien revisa en el Visual Foxpro en el menu Herramientas (tools), Options (opciones), en la pestaña Regional... en donde dice Use System Setting, revisa que este deshabilitado...
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

do cpzero

Publicado por Luighi (105 intervenciones) el 01/04/2008 02:00:36
hay un programita que viene con visual foxpro y que resuelve ese problemita
se llama cpzero.prg
en visual foxpro 9 está ubicado en:
C:Archivos de programaMicrosoft Visual FoxPro 9ToolsCpzero
supongo que en visual 6 está en alguna ubicación parecida
lo único que tienes que hacer es copiar ese prg en la misma ubicación donde tienes los formularios
vamos a suponer que tienes el formulario babilonia.scx
entonces escribe lo siguiente en la ventana de comandos:
do cpzero with "babilonia.scx",getcp()
se abrirá una ventana de diálogo donde tendrás que elegir un valor
no sé realmente qué es lo que te podrá estar mostrando con respecto a lo que estás viendo pero de la lista que te aparece
prueba eligiendo el código de pagina 1252
luego corre el formulario:
do form babilonia
si aún no resulta ejecuta nuevamente:
do cpzero with "babilonia.scx",getcp()
y ahora elije 850 que es la página de códigos para latinoamérica
si aún no resulta elije 437 que es para USA
y etc
al parecer la página de códigos que usas está siendo predeterminado por el sistema operativo, eso lo averiguas con cpcurrent() escribiéndolo en la ventana de comandos, tiene que arrojarte 1252, si no es así entonces en la carpeta de visual foxpro crea un archivo llamado config.fpw y dentro escribe:
codepage=1252
lo guardas y listo, sigue trabajando sin problemas
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar