FoxPro/Visual FoxPro - grid problema

   
Vista:

grid problema

Publicado por ovelit. (126 intervenciones) el 16/04/2008 18:47:57
tengo el siguiente problema

tengo un boton donde hago una consulta y la muestro en un grid, hasta hay todo va bien

ahora cuando yo por ejemplo le de click a la column4 del grid por ejemplo en el evento click

para que me visualic algo en una caja de texto no me visualiza nada que estara pasando sera que como estoy llenando el grid desde una consulta me da ese problema y como lo puedo solucionar.
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder

RE:grid problema

Publicado por sergio (697 intervenciones) el 16/04/2008 21:17:29
El cuadro de texto pertenece a la columna del grid o es un cuadreo de texto fuera de la grid
Si es un cuadro de texto fuera de la grid, lo qu etenes que hacer es en el metodo
afterrow..........
beferorow........
escribir codigo para que alimente el value de l acaja de texto
pero la verdad que no se bien lo que necesita y donde esta el cuadro de texto
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:grid problema

Publicado por ovelit (126 intervenciones) el 16/04/2008 21:27:16
es el cuadro de texto que esta dentro de la columna del grid
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:grid problema

Publicado por ovelit (126 intervenciones) el 16/04/2008 21:27:31
es el cuadro de texto que esta dentro de la columna del grid
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:grid problema

Publicado por jorge (422 intervenciones) el 16/04/2008 23:11:47
Hola
y que codigo pusiste en el textbox de la columna 4 de el Grid???
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:grid problema

Publicado por ovelit (126 intervenciones) el 17/04/2008 00:52:17
el problema es el grid no el codigo q coloque en el text1 de la columna4 del grid

el codigo es un simple mensaje para probar

messagebox('prueba')
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:grid problema

Publicado por kong (681 intervenciones) el 17/04/2008 05:48:47
si la columna tiene un campo de alguna tabla, entonces lo unico que vas a poder visualizar es contenido de ese campo en la referida tabla......Por lo tanto, si quieres que aparezca algo distinto en esa columna, debes cambiar valores en los registros en la tabla o cursor referida.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:grid problema

Publicado por jorge (422 intervenciones) el 17/04/2008 17:21:23
Hola
y el Grid es de solo lectura?. esta habilitado?
no tiene nada que ver la consulta.... tampoco tiene que ver el evento donde pusiste el codigo del textbox de tu columna4, es decir, en el valid, click, gotfocus, when, lostfocus, keypress, en cualquiera de ellos debe de funcionar. salvo que en esa columna tengas otro objeto, chekbox, combobox. y el GRID este para funcionar con alguno de estos, en lugar del textbox.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:grid problema

Publicado por ovelit (126 intervenciones) el 17/04/2008 17:43:30
no el grid no le e insertado ningun otro ojbeto tiene los q trae por defecto osea los textbox

y la columna4 donde le programo x rutina esta readonly=.f.

lo que pasa es lo siguiente la primera ves q ejecuto el form se realiza la consulta y se llena el grid y si puedo manipula la columna4 y se me ejecuta el codigo que esta en ese columna4 osea en el texbox....

ahora cuando yo presiono el boton para hacer otra consulta y se me llene el grid, hace la consulta, me llena el grid, PUEDO MANIPULAR LA COLUMNA4 PERO NO SE ME EJECUTA EL CODIGO DE ESA COLUMNA..

QUE ESTARA PASANDO AHI

REFRESCO EL GRID Y NADA YA NO SE QUE HACER
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:grid problema

Publicado por jorge (422 intervenciones) el 17/04/2008 22:18:19
Te mande un ejemplo de como uso el grid a tu correo que indicas arriba
saludos
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

listo solucionado grid problema

Publicado por ovelit (126 intervenciones) el 17/04/2008 23:01:37
ok foxeros porfin di con el problema era una tonteria pero me dio dolor de cabeza

cuando les pase esto que me paso a mi lo que hay que hacer es limpiar el grid osea asi

thisform.grid1.RecordSource=" "
thisform.grid1.RecordSource=SQLExec(conexion, 'SELECT * FROM tabladeajuste ','detalle')

eso era todo el problema que antes de hacer la consulta y llenar el grid tenia que limpiar el RECORDSOURCE.

ANTA LA PROXIMA FOXEROS
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar