GeneXus - Perdida Capacidad de Compilar

   
Vista:

Perdida Capacidad de Compilar

Publicado por Chaly (54 intervenciones) el 21/08/2008 15:46:47
Estimados amigos:

Tengo una aplicación en Gx 9.0 - .Net- Sql server 2000 - WEB, los pasos para correr la aplicación, cuando se producen ajustes o modificaciones al programa es:

1. Especificar.
2. Generar.
3 Compilar

De pronto mi modelo, perdió la capacidad de Compilación, es decir que cuando le ordeno ejecutar la fase de compilación, ejecuta el procedimiento como si los programas no hubiesen sufrido cambios, a pesar de que si fueron, por lo tanto cuando se ejecuta la aplicación, los cambios introducidos no aparacen. alguien tuvo este problema y sabe como resolverlo.

Muchas gracias de antemano.

Chaly
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder

Problema Resuelto

Publicado por Chaly (54 intervenciones) el 22/08/2008 17:29:37
Estimados amigos:

Ya resolví el problema, lo comento por si alguien se le da en alguna ocasión:

A veces no nos damos cuenta de pequeños detalles, pero que al final repercuten en el funcionamiento del programa y lo que es peor, hacen que nos rompamos la cabeza buscando soluciones complejas a problemas minusculos.

Por alguna razón aún no determinada, la fecha del sistema de mi PC se atraso un mes, GeneXus tiene un sistema que trabaja en base a la verificación de las fechas del sistema y que la misma esté actualizada, en ese sentido, ha bloqueado cualquier actualización que se pueda realizar, tanto a nivel de especificación, generación y compilación, una vez reajustada la fecha del sistema, agarró todos los programas modificados y los especifico, los genero y finalmente los compiló.

Saludos a todos.

Chaly
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar
Imágen de perfil de Patricio Ojeda V

RE:Problema Resuelto

Publicado por Patricio Ojeda V (454 intervenciones) el 22/08/2008 21:56:31
Cuando se cambia la fecha del pc pueden eventualmente pasar ese tipo de problemas.

Las posibles soluciones para ese tipo de problemas son obviamente volver el equipo a la fecha que corresponda, si con eso no se arregla se deben borrar los archivos .ari y .ver del modelo, o tambien hacer un Build All con Force Generation.

Patricio Ojeda V
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar