GeneXus - Procedimientos con Webservices

   
Vista:
Imágen de perfil de Pablo Dante

Procedimientos con Webservices

Publicado por Pablo Dante (10 intervenciones) el 25/08/2015 15:58:55
Hola Foro.

Buen día.

Tengo un inconveniente con la generación y compilación de un Procedimiento que consume; en este caso actualiza por medio de un Webservices datos en otro sistema.
El Procedimiento es llamado desde un Web Panel que "Main"; a través de un Evento en este caso el "Enter".
El Procedimiento consume un "WS" y elimina registro o sea debe hacer un "Delete" lógico, este objeto tiene sus propiedades estándar o sea que se ejecuta y actualiza una tabla.
El problema en este caso no es la lógica del objeto en si, sino cuando el mismo se ejecuta. O sea se hacen los cambios se genera, especifica y compila sin problemas.
Pero cuando se ejecuta la llamada en el servidor este no encuentra el objeto y tira un Error 404.
Lo que note al compilar que el objeto se genera como "pMiProcedimientoX"; pero cuando lo ejecuto en el servidor me indica que lo que no encuentra es "aMiProcedimientoX"... ???
O sea genera y compila anteponiendo la letra "p" al objeto en cuestión, y, cuándo lo ejecuto el servlet quiere ejecutar un objeto que comienza con la letra "a"... Esto es lo que no comprendo !!?
Es como que el llamador invoca a un Report y no un Procedur... !!! :(
Si alguien puede decirme cual puede ser el problema, o le pasó algo similar y me puede guiar se lo voy a agradecer.

Les paso el ambiente en donde estoy trabajando...

- Genexus 9 - Web
- Generador Java
- DBMS AS400 iSeries
- Tomcat 5.5

Un saludo cordial.
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder