HTML - quiero enclavar un boton

   
Vista:

quiero enclavar un boton

Publicado por jordi martin (1 intervención) el 29/04/2015 17:36:23
Hola a todos

He puesto este tema en el foro de HTML, pero no esta de mas ponerlo aqui tambien

ante todo me presento, soy Jordi y no provengo de este mundillo sino que tan solo soy un usuario para mis proyectos de automatismos

intento hacer un sistema de supervisión y accionamiento, scada, mediante web, que accione unos mecanismos, concretamente una camara frigorifica.

Esta web, que todavia tengo en modo local haciendo pruebas, y que desenvolupo gran parte de ella mediante dreamveawer, tiene lo siguiente.-

un cuadro sinoptico del esquema de la camara frigorifica, con una serie de pilotos que indican el funciomiento o paro de los actuadores, todos ellos accionados mediante un automata llamado arduino, y todo ello manejado por un ordenador de bajo coste como es una raspberry pi.

tambien dispone de unos interruptores l que son formados por dos imagenes, una en on y otra en off, la cual cambia de posición, o sea de imagen, al hacer click con el raton

Mediante jquery, para cada imagen on de los interuptores, derivo la acción hacia una pagina php que me ejecuta un programa en python que activa los mecanismos, sin recargar la pagina

hasta aqui todo correcto, y supone, juntamente con la visualización de algunos sensores de temperatura de la propia camara, una herramienta muy util y versatil para los tecnicos de mantenimiento de este tipo de instalaciones frigorificas industriLes, pudiendo enviar alarmaa, monitorizar parametros....a traves de un ordenador, tablet o el mismo smartphone, independientemente del sistema utilizado

El problema que tengo es el siguiente, pongamonos en situación.-

abro la pagina, observo los parametros, activo el motor de la camara y cierro el navegador...hasta aquí correcto

si yo quiero al cabo de un rato monitorizar otra vez todo el tema de sensores o activar otro mecanismo de la camara frigorifica, debo entrar otra vez con el navegador y teclear la ip de la web....el problema es que cada vez que actualizo la web, me vuelve a la posicion inicial off todo aquello que estaba en posicion on antes de entrar a la pagina, parandome la ejecución de dichos motores y teniendo que volver a rearmar el motor

mi pregunta es la siguiente.-
que debo hacer para que al actualizar la pagina, no vuelva a mostrar la posición inicial del interruptor y se me quede fijo en la posición que yo haya dejado en su momento....lo normal es que tu actives un motor y cuando quieras consultar la temperatura de la camara, esta siga funcionando.

espero haber explicado mi problema

gracias por adelantado
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
-1
Responder