Utilizamos cookies propias y de terceros para mejorar la experiencia de navegación, y ofrecer contenidos y publicidad de interés.
Al continuar con la navegación entendemos que se acepta nuestra política de cookies.
Iniciar sesión Cerrar
Correo:
Contraseña:
Entrar
Recordar sesión en este navegador
Iniciar sesiónIniciar sesiónCrear cuentaCrear cuenta

HTML - ¿uso de varios formularios en una sola página?

Vista:
Me gusta: Está pregunta es útil y esta clara
0
No me gusta: Está pregunta no esta clara o no es útil
 
Asunto:

¿uso de varios formularios en una sola página?

Autor:fjmasero (3 intervenciones)
Fecha:11/03/2004 13:00:10
Wenas:
Estoy desarrollando para un portal.
Hay un formulario permanente, q sirve para logearse en cualquier momento.
Dependiendo de las páginas por las q se navegue, puede haber + formularios.
La pregunta q hago es si se pueden poner + de 1 <form>...</form>, con diferentes id y name evidentemente, dentro de una misma página. Si es q si, si es una práctica habitual, ¿q cuidados hay q tener?.
Me suena q cuando me contaron esto del html, me dijeron q no, pero ...
El problema q tengo, y q me provoca esta duda, es q ahora mismo tengo un solo formulario q engloba a las diferente páginas, de tal forma q si se abre una sin otros formularios a cumplimentar, solo habrá los campos del login, y si se abre una con otro formulario a cumplimentar, estarán los campos del login + los del 2º formulario.
Por el diseño, el login está puesto antes de una animación flash, la cual está dentro de <form></form>, puesto q los posibles campos de los segundos formularios a cumplimentar están detrás de la animación.
La cuestión es q cuando hago un recorrido por el formulario de la página, según las diferentes funcionalidades, con el típico javascript for(i=0;i<document.formulario.length; i++), "entra" en la animación, como si fuera parte del formulario.
En las trazas q he puesto de prueba, el name, el id me lo da vacio, y el value undefined.
He comprobado q es la animación pq si la quito, no me pasa. Tb he comprobado q si la pongo incluso po detras del boton de submit, tb "entra".
¿Se os ocurre q puede ser y como solucionarlo?.
Espero haberme explicado, pq entiendo q es un poco caótico el temita.
Salu2 y gracias.

Responder
información
Otras secciones de LWP con contenido similar...