Informix - shared memory

   
Vista:

shared memory

Publicado por Alex (3 intervenciones) el 18/10/2010 22:48:51
al darle oninit -v me sale el siguiente error por favor alguien me podria ayudar
[informix@posrey usr]$ oninit
[informix@posrey usr]$ onstat -d
shared memory not initialized for INFORMIXSERVER 'posrey'
[informix@posrey usr]$ onnit
-bash: onnit: command not found
[informix@posrey usr]$ oninit -v
Checking group membership to determine server run mode...succeeded
Reading configuration file '/home/informix/etc/onconfig.posrey'...succeeded
Creating /INFORMIXTMP/.infxdirs...succeeded
Creating infos file "/home/informix/etc/.infos.posrey"...succeeded
[informix@posrey ~]$ oninit -v
Checking group membership to determine server run mode...succeeded
Reading configuration file '/home/informix/etc/onconfig.posrey'...succeeded
Creating /INFORMIXTMP/.infxdirs...succeeded
Creating infos file "/home/informix/etc/.infos.posrey"...succeeded
Linking conf file "/home/informix/etc/.conf.posrey"...succeeded
Writing to infos file...succeeded
Checking config parameters...succeeded
Allocating and attaching to shared memory...succeeded
Creating resident pool 18872 kbytes...succeeded
Allocating 18384 kbytes for buffer pool of 2K page size...succeeded
Initializing rhead structure...succeeded
Initializing ASF...succeeded
Initializing Dictionary Cache and SPL Routine Cache...succeeded
Bringing up ADM VP...succeeded
Creating VP classes...succeeded
Onlining 0 additional cpu vps...succeeded
Onlining 2 IO vps...succeeded
Initialization of Encryption...succeeded
Forking main_loop thread...succeeded
Initializing DR structures...succeeded
Forking 1 'soctcp' listener threads...succeeded
Starting tracing...succeeded
Initializing 1 flushers...succeeded
[informix@posrey ~]$
este es el error lo de arriba no termina de levantar el informix
[informix@posrey usr]$ onstat -d
shared memory not initialized for INFORMIXSERVER 'posrey'
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder

RE:shared memory

Publicado por René (64 intervenciones) el 23/11/2010 22:54:04
Hola, ya checaste el user y group informix que el id sea igual o mayor a 100? Me suena a que le cambiaron algo en los atributos del usuario, checa el /etc/passwd

Checa los permisos de los directorios, verifica que no tengas segmentos de memoria que se hayan quedado atrapados, semaforos, colas, etc.

Despues vuelve a intentar levantar.

saludos.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:shared memory

Publicado por alex (3 intervenciones) el 09/12/2010 15:58:23
gracias lo revisare
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:shared memory

Publicado por Orlando Lizarazu Tello (8 intervenciones) el 02/03/2011 02:56:44
verifica el archivo online.log con el comando less o vim y verifica que error te esta dando al arrancar. este archivo por lo general se encuentra en $INFORMIXDIR/etc.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:shared memory

Publicado por alex (3 intervenciones) el 02/03/2011 21:26:48
Ok Gracias
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar